PDA

View Full Version : SUPER SLOW save times



patricks
2009-12-09, 01:57 PM
Revit 2010 x64, non-workshared file, all Cat6 patch cables and in-wall cable, connected to the server through a gigabit switch. Network properties confirms 1.0 Gbps connection.

I opened this 18 MB non-workshared file, made a small change on a sheet, then saved it. Save took 92 seconds!!!

In contrast, a workshared file of similar size took less than 10 seconds to SWC and save locally before and after.

Anyone else seen this kind of slow times with non-workshared files stored on a server?

patricks
2009-12-09, 02:19 PM
I tried a straight copy of that same non-workshared file from the server to my local machine, and the transfer was nearly instant. Saving the file on my local machine took less than 3 seconds.

Perhaps it's just a characteristic of Revit to have long save times of non-workshared files stored on a network location?

bregnier
2009-12-09, 04:15 PM
I have seen little difference in save times between workshared and non-workshared files under similar conditions to above. Sounds like a network hiccup to me... have you tried non-workshared files in multiple locations?

patricks
2009-12-09, 04:42 PM
Non-workshared files at all workstations with Revit installed in the office always take forever to save. Workshared files are fine, just 10-30 seconds depending on size of file and number of changes it has to update between files.

We actually found yesterday that the server was connected directly to our SonicWall firewall, which is only capable of 100 Mbps. We switched the cable to a wall terminal, which goes through the gigabit switch (server no longer has to go through the firewall when communicating with terminals). However Revit save times remain the same.

iru69
2009-12-09, 05:01 PM
I don't know if you're having the same issue as we did, but this stumped us for years. As is often the case, the issue seems unique to Revit - every other app we use saves in a timely fashion. Not sure if it's related to Windows Server, or RAID, or both. I know that I can save a Revit file over the network to another workstation (e.g. Windows XP; no RAID) and it saves relatively quickly.

The fix for us was to enable write caching and enable advanced performance on the server's hard drive. This made a huge world of difference.

Windows Server > Computer Management > Storage > Disk Management > Properties (of applicable Disk) > Policies > Enable write caching on the disk; Enable advanced performance.

It does come with the caveat that it's a very good idea to have the server hooked up to a UPS with write caching enabled.

I by chance came across the "fix" in another thread here on AUGI a while back, but a forum search came up empty.

patricks
2009-12-09, 05:06 PM
By UPS you mean battery backup right? Uninterruptable Power Supply. Yeah our server and even the network equipment (modem, firewall, switch etc.) is all on a backup power supply.

I will definitely give that a shot. One of our IT consultants is coming by this afternoon so I'll probably ask him about that first, though.

iru69
2009-12-09, 05:10 PM
By UPS you mean battery backup right? Uninterruptable Power Supply.
Yes.

I should have also added that the exact sequence to enable write caching that I describe is on a Windows 2008 server. Other versions of Windows server might be slightly different, but the option should still be there.

patricks
2009-12-09, 05:21 PM
hmm under policies for that disk drive, there is already a radio button selected that says "optimize for performance" which includes write caching. The options are also grayed out, so I cannot change that option.

I do not see separate Write Caching and Advanced Performance check boxes. It's only the radio buttons (the other option is to optimize for disk removal).

This is Windows Server 2003, regular flavor, no Exchange or anything.

iru69
2009-12-09, 06:06 PM
If it's greyed out, it sounds like you're selecting the properties of a partition rather than the whole drive (see attached image).

If write caching is already enabled on the server, it would appear you're experiencing a different issue than the one we had (or Windows 2003 Server handles it differently).


hmm under policies for that disk drive, there is already a radio button selected that says "optimize for performance" which includes write caching. The options are also grayed out, so I cannot change that option.

I do not see separate Write Caching and Advanced Performance check boxes. It's only the radio buttons (the other option is to optimize for disk removal).

This is Windows Server 2003, regular flavor, no Exchange or anything.

patricks
2009-12-09, 07:12 PM
yep, I right-clicked there and went to Properties > Policies, and I see the same box as you show on the right side there, but without those 2 checkboxes. The 2 radio buttons are there, grayed out just like in your image, but with nothing below it. Weird.

*edit* this is an HP Proliant server with two 250 GB SCSI drives in RAID 1 configuration.

iru69
2009-12-09, 10:17 PM
Frustrating. It should be there in W2K3. The only other thing I think of trying is accessing something like the HP Array Configuration Utility that might be provided with the server and/or directly on the RAID card firmware settings (usually accessible at boot-up).

I did see something-somewhere about HP/Compaq servers need to have a UPS software utility installed to let the RAID driver know that a UPS is running and it's okay to enable the Advanced Performance check-box... but I don't know if that's still applicable.

You or your IT guy might want to do a little googling, but I hate to send you on a wild goose-chase either.

Just to double-check it's the server, try setting up a shared folder on the network on someone elses workstation (i.e. a regular computer and not a server) and then try saving to that folder over the network - it should be much faster. If it's still slow, that might point to something besides the server.

Best of luck!


yep, I right-clicked there and went to Properties > Policies, and I see the same box as you show on the right side there, but without those 2 checkboxes. The 2 radio buttons are there, grayed out just like in your image, but with nothing below it. Weird.

*edit* this is an HP Proliant server with two 250 GB SCSI drives in RAID 1 configuration.

patricks
2009-12-10, 06:14 PM
Did some testing yesterday w/ IT consultant. Incidentally, he said normally he does not do the write caching and all that stuff on servers, but anyway...

I did try saving the same file to another workstation, and it took less than 10 seconds. We looked at various other TCP/IP and other network settings (name resolution, whatever that is, etc.) on my workstation, but really nothing helped when saving the file directly to the server.

Something we noticed is that sometimes when saving, it would hang for over a minute and then actually write the file fairly quickly. Other times, it would write the file immediately, and then hang for 40-60 seconds. Really weird.

I have also tried various scenarios using both the mapped network drive location Z:\AERC\...\etc. as well as the actual network location \\server\AERC\...\etc. and both went about the same.

Everything is going through the same gigabit network switch, be it terminal to server, or terminal to terminal. So it must be either an issue with the server, or just a characteristic of Revit itself when saving to a network location.

iru69
2009-12-10, 09:31 PM
Did some testing yesterday w/ IT consultant. Incidentally, he said normally he does not do the write caching and all that stuff on servers, but anyway...
I normally wouldn't enable it either... but that's Revit for you.

If it's the same for everyone on the network (saving that same file or similar to the server), and not just slow from your computer, all your symptoms sound exactly like what we were dealing with. I'd put my money on the Write Caching and Advanced Performance check-boxes. We lived with the slow saves for years, and the difference was night and day on our server. Sorry your server doesn't seem to be cooperating. Best of luck.

:beer:

patricks
2009-12-11, 01:11 PM
It happens to all Revit users, with any NON-workshared files. SWC times are completely acceptable, usually in the 10-20 second range. But these 10MB non-workshared files are taking upwards of 60-90 seconds to save.

Did some more testing today, this time saving the file to two different external USB drives that are attached to the server. In all cases, using all save path options (mapped drive or network path) yielded fast times of only 4 to 8 seconds. Tried both opening a local file and saving to those drives, and making a change to the files on those drives and saving back. Still fast save times.

The problem seems to be ONLY when saving a file to the actual server C drive. We have 2 different shared folders on the server's C drive (which is RAID 1 mirrored), the Z drive and the X drive. Saving to either location yields save times of 60+ seconds.

truevis
2009-12-11, 01:59 PM
Could your anti-virus software be affecting the problem?

patricks
2009-12-11, 03:52 PM
Could your anti-virus software be affecting the problem?

I don't see how it could. We actually just implemented an all-new office-wide antivirus solution from Trend Micro, installed on the server and all work stations. But we've had issues like this for years prior to this new AV software.

cliff collins
2009-12-11, 04:14 PM
Just a couple of questions:

Why have non-worksetted projects on the server? If only one person is working on them, just keep them on the local machine?

Or--just set up worksets and move ahead with multi-users and place on the server?

I have never seen the slow save times you are describing, and do not understand why
that is happening, since we do not have non-workset enabled projects on the server.

cheers...........

patricks
2009-12-11, 04:28 PM
Just a couple of questions:

Why have non-worksetted projects on the server? If only one person is working on them, just keep them on the local machine?

Or--just set up worksets and move ahead with multi-users and place on the server?

I have never seen the slow save times you are describing, and do not understand why
that is happening, since we do not have non-workset enabled projects on the server.

cheers...........

Because ALL office-related files are stored on the server, on RAID 1 mirrored storage, with separate external RAID 1 mirrored storage for backups run every night, and battery back-up power in place. Workstations do not run backups every night, nor do all workstations have battery backup (wish they did, though).

Yes we could copy the files back and forth each day, but that's just another potential for human error (forgetting to copy the file one way or the other, working on a file that's in the wrong place, etc).

Most of our smaller, more simple project like simple tenant fit-outs with only one person working on it will typically remain non-workshared. Also early stages of a project will tend to be non-workshared and then change to workshared when more people are needed to work on it.

I'm starting to think we should just enable worksets from the beginning, even if there's only the default worksets to start out, then more added later. But still, I REALLLY want to know why non-workshared files take so friggen long to save to the server C drive.