View Full Version : XREF Panel Opens Very Slow - First Time Only

2012-05-18, 02:51 PM
My xref window is taking way too long to open, but only the first time after launching the program. My machine specs are pretty high (multi-core i7, 12GB RAM, Win7x64, etc). To get some metrics for comparison - looks like AutoCAD starts up within 10 seconds or so, but the first time I open the xref panel it is about 45 seconds. If I close the xref window and reopen it, the panel opens immediately. Restart AutoCAD and it takes forever again.

Recently installed 2013 and thought this was just a 2013 issue, but it looks like my 2012 is having the same problem. One of the other users here had this issue the other day - it took long enough on his 2013 install that he thought it had froze and killed it a couple times. His 2012 seemed to work fine. All AutoCAD MEP installs by the way.

Anyone seen this before? All my searches seemed to come back talking about problems about large xref'ed files, this even happens in our template file (no xrefs attached). Seems to be independent of what drawing is open as well.

Brian Myers
2012-05-20, 02:51 PM
Out of curiosity, does this occur with an local XREF as well (an XREF hosted on your own computer). It's an easy enough test, save a large file to your own computer, launch AutoCAD, xref in that file, save/close AutoCAD and then open it to see if it loads slow.

It's likely this won't make a difference, but if it does, then this gives us a big lead toward the potential cause of the issue.

Also, I've seen on rare cases that Virus scanning software will cause this. They will load it quick when they don't think they have to scan the file, but when it thinks this could be a "new file" it scans the file...thus taking longer to load.

2012-05-21, 01:23 AM
My problem is similar, but goes beyond just xrefs.

Every time I open xrefs or click on an xref, says not responding. Binding a 7mb file xref saved on the computer causes the system to crash (it processes it to 99% very quickly but doesn’t finish the command). The windows task monitor would only show my memory use at sitting around 4.13gb in acad Map, and only 3.84 in acad 2013; with 25% CPU usage.
Prior to this the programs would not open due to a Fatal Error, where a when I tried to repair it will not let me repair or uninstall. To resolve this help desk ended up deleting my user profile on win7 then creating a new one.

I checked to see that I was running 64 bit versions of AutoCAD (which I was), but the problems of it crashing, or not responding when I pulled up menus (xref, properties, tried to bind xrefs or click on them, or even just performing align commands or move etc).

I just don’t understand why my system is failing at executing such simple commands when the computer is more than adequate spec wise.

PC specs are:
Intel xeon cpu @2.93 ghz, 24GB Ram
Win 7 64 bit OS, running 64 bit Autocad, Autocad Map3d 2012 products.

2012-05-21, 02:56 PM
I tried Brian's first suggestion about making a file with local xrefs, but the problem remained. About the virus scanner, I was hopeful about this - I've been testing out a different anti-virus/firewall/etc program recently, and thought the time periods overlapped enough that this could be it. Unfortunately when I disabled the security software it doesn't seem to affect anything.

But I did get somewhere just now. I tried switching to a different ACAD profile and the issue went away. So I started comparing settings between the two. We've got a folder on the network with all of the misc fonts we have accumulated, and map that into the Support File paths. If I take this item out of the Support File Paths the xref issue goes away, if I add it back the problem returns.

So onto the related question - has anyone had problems with putting the fonts in a centralized location on the network and mapping that directly to the AutoCAD paths? As a MEP company we do occasionally get architects using custom fonts for title blocks and such that we need to use. We've only got a handful of users, but 1 network location is easier to maintain than a bunch of individual machines, some with multiple AutoCAD versions. We used a network location for fonts at my previous firm without issue, and only recently noticed problems here.

Edit: I dug around a bit, it appears that AutoCAD uses the default windows location for all TTF files, and looks for the SHX fonts in the Support Paths. After I pulled the TTF fonts out of the network location that folder got much smaller and more responsive. It doesn't seem to be causing anymore issues when I added it back into the Support Paths.