Results 1 to 8 of 8

Thread: Shift to Deselect doesn't work

  1. #1
    Member
    Join Date
    2007-12
    Location
    Indiana
    Posts
    9
    0 Did you find this post helpful? Yes

    Exclamation Shift to Deselect doesn't work

    I have a habit of using shift to deselect objects when I have selected too many. Ever since I got this new PC with Win7 on it with “raster Design 2010 on AutoCAD Electrical 2010” I haven’t been able to deselect an object with using the shift key. Actually what happens is my curser won’t even move if I hold down the shift key. But the “R” and “A” function work fine. But I’m a creature of habit and like to use the shift key.

    I have tried to go into “options” under the selection tab and still nothing worked. I even tried to go into the CUI and see if there was a setting for the shift+left click in there. Still found nothing. I also tried “PICKADD”, nope that didn’t work either.
    I’m completely at a loss. I have search all over this forum and others and still haven’t found out what the reason is that I can’t find the setting to fix this issue. While I’m thinking about it I have a wireless intellimouse, if that matters.
    Is there anyone out there that has a fix for this problem I’m having?

  2. #2
    Geospatial Moderator Jmurphy's Avatar
    Join Date
    2000-11
    Location
    South Eastern US, exact location unknown
    Posts
    1,517
    0 Did you find this post helpful? Yes

    Default Re: Shift to Deselect doesn't work

    Go into the raster options "ioptions" in the user's preferances tab, uncheck the Shift + Left click there under the mouse settings.

    Shift + Left-Click Image Select Enables you to select images by placing your cursor over them and holding the Shift key down while clicking your left mouse button. This feature is useful when you are zoomed in to the image and cannot see the image frame. For more information, see Selecting an Image.
    Note When you activate Shift+ Left-Click Image Select here, it overrides the AutoCAD Shift+ Left-Click to deselect entities for pickfirst and grip editing.
    J. Murphy
    AKA
    Murph
    The former AutoCAD MAP3D Power User

  3. #3
    Member
    Join Date
    2007-12
    Location
    Indiana
    Posts
    9
    0 Did you find this post helpful? Yes

    Default Re: Shift to Deselect doesn't work

    Awesome, You are the man! That fixed my deselecting issue, BUT when I hold down the shift key my curser won't move? I have to actually place my cross hairs over the object first then hold the shift key and select the object. Is there a fix or an option for that?
    But hey I'm pretty happy about being able to deselect using the shift key. Thank you!

  4. #4
    100 Club Openwheeler's Avatar
    Join Date
    2006-11
    Location
    Heartland of the Mid-west, home of the Indy 500
    Posts
    156
    0 Did you find this post helpful? Yes

    Thumbs up Re: Shift to Deselect doesn't work

    Quote Originally Posted by Jmurphy View Post
    Go into the raster options "ioptions" in the user's preferances tab, uncheck the Shift + Left click there under the mouse settings.

    Shift + Left-Click Image Select Enables you to select images by placing your cursor over them and holding the Shift key down while clicking your left mouse button. This feature is useful when you are zoomed in to the image and cannot see the image frame. For more information, see Selecting an Image.
    Note When you activate Shift+ Left-Click Image Select here, it overrides the AutoCAD Shift+ Left-Click to deselect entities for pickfirst and grip editing.
    This works, but you have to open the Raster Design on AutouCAD in my version to get those options within the "ioption", then get out of the file and back in it, and it should be fine. Worked for me!

    Thanks Murph.

    On a side note Murph...Brickyard is at the end of July, let me know if you going to make the trip this year.
    God Speed to All....

  5. #5
    100 Club Openwheeler's Avatar
    Join Date
    2006-11
    Location
    Heartland of the Mid-west, home of the Indy 500
    Posts
    156
    0 Did you find this post helpful? Yes

    Thumbs up Re: Shift to Deselect doesn't work

    Quote Originally Posted by Jmurphy View Post
    Go into the raster options "ioptions" in the user's preferances tab, uncheck the Shift + Left click there under the mouse settings.

    Shift + Left-Click Image Select Enables you to select images by placing your cursor over them and holding the Shift key down while clicking your left mouse button. This feature is useful when you are zoomed in to the image and cannot see the image frame. For more information, see Selecting an Image.
    Note When you activate Shift+ Left-Click Image Select here, it overrides the AutoCAD Shift+ Left-Click to deselect entities for pickfirst and grip editing.
    This works, but you have to open the Raster Design on AutouCAD in my version to get those options within the "ioption", then get out of CAD, get back in it, and it should be fine. Worked for me!

    Thanks Murph.

    On a side note Murph...Brickyard is at the end of July, let me know if you going to make the trip this year.

    Cheers!
    God Speed to All....

  6. #6
    Member
    Join Date
    2007-12
    Location
    Indiana
    Posts
    9
    0 Did you find this post helpful? Yes

    Default Re: Shift to Deselect doesn't work

    Yes, this function works, but the cursor won't move once I push down on the shift key. Anyone have an idea why that happens?

  7. #7
    100 Club Openwheeler's Avatar
    Join Date
    2006-11
    Location
    Heartland of the Mid-west, home of the Indy 500
    Posts
    156
    0 Did you find this post helpful? Yes

    Lightbulb Re: Shift to Deselect doesn't work

    Quote Originally Posted by dutch724 View Post
    Yes, this function works, but the cursor won't move once I push down on the shift key. Anyone have an idea why that happens?
    I have no idea. I use the fence to deselect unwanted grabbed features, just habit for me.

    Here's another little tip for all in regards to Murphy’s post and "ioptions" setting change. If you have an image and the feature or features are within that image, it will grab that image and not deselect the feature; outside the image it works. I tried to turn off the image and unload, but it still grabs the frames of the image, I got around it by turning off/freeze the layer that the image is on so I can deselect features within the image boundary.

    Murph or anyone want to add anything to this tip or any other comments towards this topic?
    God Speed to All....

  8. #8
    Geospatial Moderator Jmurphy's Avatar
    Join Date
    2000-11
    Location
    South Eastern US, exact location unknown
    Posts
    1,517
    0 Did you find this post helpful? Yes

    Default Re: Shift to Deselect doesn't work

    Quote Originally Posted by Openwheeler View Post
    This works, but you have to open the Raster Design on AutouCAD in my version to get those options within the "ioption", then get out of CAD, get back in it, and it should be fine. Worked for me!

    Thanks Murph.

    On a side note Murph...Brickyard is at the end of July, let me know if you going to make the trip this year.

    Cheers!
    Nope won't be making it to the Brickyard I'm back among the employed temporary, just not in CAD, Map or civil work.
    J. Murphy
    AKA
    Murph
    The former AutoCAD MAP3D Power User

Similar Threads

  1. Hold down Shift key to deselect Objects not working
    By smooth shoes in forum AutoCAD General
    Replies: 15
    Last Post: 2010-08-18, 09:08 PM
  2. Attached image and shift-deselect conflicting
    By jgrande26 in forum AutoCAD General
    Replies: 6
    Last Post: 2009-10-26, 06:49 PM
  3. YES or NO to all doesn't work???
    By csmac2004 in forum Productstream - General
    Replies: 1
    Last Post: 2009-03-03, 06:31 PM
  4. Specify New Work Plane - doesn't work?
    By bnelson.188587 in forum Revit Architecture - General
    Replies: 1
    Last Post: 2008-07-24, 04:50 PM
  5. Replies: 4
    Last Post: 2007-06-06, 07:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •