Results 1 to 3 of 3

Thread: Install Problems - Microsoft Visual C++ 2010

  1. #1
    100 Club
    Join Date
    2008-10
    Location
    Auckland, New Zealand
    Posts
    115
    0 Did you find this post helpful? Yes

    Default Install Problems - Microsoft Visual C++ 2010

    Hi Guys,

    Not sure if anyone else has run into this yet, but i've now had this happen on a few installs of various Autodesk Software. The install fails to complete because there is a newer version of the C++ 2010 Redistributable on the machine - the installer isn't smart enough to by default ignore this...

    Microsoft Visual C++ 2010 Redistributable Setup - Installation Log
    Installation Blockers:
    1.A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine.

    Global Block Checks: StopBlockers evaluated to true.
    Final Result: Installation failed with error code: (0x000013EC), "A StopBlock was hit or a System Requirement was not met." (Elapsed time: 0 00:00:00).

    Revit install INI file:
    [VCREDIST2010X86]
    PLATFORM=ALL
    PRODUCT_NAME=Microsoft Visual C++ 2010 Redistributable (x86)
    EXE_PATH=3rdParty\x86\VCRedist\2010\vcredist_x86.exe
    EXE_PARAM=/q /l %temp%\vcredist_x86_2010.log
    VC_FUNC=VCx86RedisCheck
    VC_PARAM={196BB40D-1578-3D01-B289-BEFC77A11A1E}
    VC_SOURCE=Setup\SetupUi.dll
    PATCHES=

    Because the C++ 2010 fails to install the whole install process fails due to the requirements for installation not being met. If you add IGNORE_FAILURE=YES to the grouping i.e.

    [VCREDIST2010X86]
    PLATFORM=ALL
    PRODUCT_NAME=Microsoft Visual C++ 2010 Redistributable (x86)
    EXE_PATH=3rdParty\x86\VCRedist\2010\vcredist_x86.exe
    EXE_PARAM=/q /l %temp%\vcredist_x86_2010.log
    VC_FUNC=VCx86RedisCheck
    VC_PARAM={196BB40D-1578-3D01-B289-BEFC77A11A1E}
    VC_SOURCE=Setup\SetupUi.dll
    PATCHES=
    IGNORE_FAILURE=YES

    It will allow the install to complete but you run the risk of the installation continuing if it does actually fail for other reasons other than a newer version being detected on the machine.
    Good Morning...

  2. #2
    Member
    Join Date
    2010-06
    Posts
    13
    0 Did you find this post helpful? Yes

    Default Re: Install Problems - Microsoft Visual C++ 2010

    I had a similar issue (same?) where Revit failed to install. But what I discovered was that C++ version wasn't responsible since uninstalling whole C++ and reinstalling did not help me.
    In fact it was/is a bug in install setup for 2013 products where if you made ANY changes in Setup options your installation would fail.
    So if you have this problem try not modifying any option during setup and just install. That helped me. But my templates were not installed properly.

    Reason being, Autodesk had some problems with their Template Server and specific templates (it's been fixed now). Hope it helps someone.

  3. #3
    100 Club
    Join Date
    2008-10
    Location
    Auckland, New Zealand
    Posts
    115
    0 Did you find this post helpful? Yes

    Default Re: Install Problems - Microsoft Visual C++ 2010

    Yeah i had the same problem with the content servers also.

    The c++ problem above is a different problem, it's not Autodesk specific. There is a fair bit about it online for other software programs.

    I haven't had the issue of modifying the deployment ini file causes the install to fail, i've tweeked them a bit to work inside our corp environment.
    Good Morning...

Similar Threads

  1. Microsoft Visual Basic Error
    By cluna784254 in forum AutoCAD Civil 3D - General
    Replies: 2
    Last Post: 2011-03-30, 01:32 PM
  2. Microsoft Visual Studio 2010
    By Saimon in forum Revit - API
    Replies: 7
    Last Post: 2010-07-07, 02:52 PM
  3. Revit MEP 2010 Install Problems
    By bdavis.216450 in forum Revit MEP - General
    Replies: 2
    Last Post: 2009-04-30, 02:50 PM
  4. Microsoft Visual C++ Runtime Library
    By JOROB26 in forum Land Desktop - General
    Replies: 1
    Last Post: 2005-04-26, 06:16 PM
  5. Microsoft Visual Basic
    By jcronburg in forum VBA/COM Interop
    Replies: 1
    Last Post: 2004-06-16, 07:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •