Here's a tip I thought I'd share here.

I was recently struggling to get to grips with a good way of editing type catalogues. My main problem was that recent versions of excel decide which delimiter to use based on locale settings for your PC. In my case (and many others I found) that mean that a csv export was using a semi-colon as a delimiter instead of a comma. Excel gives no way to change that without changing the locale setting of your computer.

Being a big fan of LibreOffice (a newer branch of free / open source OpenOffice productivity suite) I thought I'd try that, and voila! As long as I import the txt file with all fields set to text (so it doesn't try and make dates from some numbers, same manual setting is required in excel) it opens great, I can make my changes and when I save again it will save as csv even though the extension stays as txt! So that's two problems solved in one go. Thanks LibreOffice developers!