Results 1 to 2 of 2

Thread: Tool palettes no longer working

  1. #1
    Active Member
    Join Date
    Cardiff, Wales, UK
    Login to Give a bone

    Default Tool palettes no longer working

    Hi all

    I am having a head ache with tool palettes and none of the treads in here have the answer for my problem. Hopefully the bright people in here will give me some clues on what is going on. Will describe the problem the best way I can:
    Created a new tool palette with a source file located on a network drive where I am the only one with full permissions and everything was working fine, including basic testing on other computers using the export/import palette for the last week; today when I was finally ready to start proper testing of the palette before rolling out to other users, the palette just stopped working on a very odd occasion. I can’t insert any of the blocks, tried all options below with no success:
    - Started the testing process with a brand new drawing from the template and started bringing the blocks from the palette, at the same time I had the source drawing open and was correcting any errors I found during the testing process. After any corrections on a particular block I would save the source file and right click on the palette block image to redefine the block, after that I would go back to the test drawing to continue with the testing.
    - After doing the above for 3 or 4 different blocks the palette just stopped inserting any of the blocks, being the ones already on the test drawing or new ones not yet tested, no message from AutoCAD if pressing F2 to check on the error;
    - Next step tried to go back to the source file and bring in any of the blocks from the palette and again not inserting and no message;
    - Next step was opening the source file from design center and create a brand new palette from the blocks inside the source file, again error messages along the following lines “block definition is not found in the source drawing….”. Palette was created blank. Source file was not open during the attempt;
    - Next tried to export the palette to a network location and import on a different computer, process worked fine and palette was created and populated but could not insert anything on any drawings, if right clicking on any of the block images within the palette choosing properties and clicking OK to close the properties the message is “Source drawing ……. For block … not found”, so again no luck;
    - Next since I am using Civil 3D 2017 for the above decided to try all of the above on AutoCAD 2017, again no luck;
    I am out of options and have no idea what is causing the problem, all my paths (support, Tool Palette File location & Authoring Palette File location) are pointing to the network location where the source file is located, blocks are all embedded into the source drawing and as I said above the permissions on the folder are correct. So what the hell is wrong.
    Any help will be greatly appreciated.
    Thanks Jaime

  2. #2
    Join Date
    Kirkland, WA
    Login to Give a bone

    Default Re: Tool palettes no longer working

    Did you get any response or resolution to your question?

    I am dealing with the same issue on our recent migration to AutoCAD 2018 & AutoCAD Architecture 2018. We didn't have any issues before but now about half of our stations are not able to use the Tool Palettes. I've tried ensuring that the folders are pointing to the same folder on the network. I did read somewhere that the Tool Palettes like to stay within the platform so it may not like the AutoCAD vs. AutoCAD Architecture versions, but I can't even create new Tool Palettes in AutoCAD and populate it with our blocks. I've tried a variety of items. I also even tried to use AutoCAD Architecture on those machines and the Tool Palettes do work, but I'm unable to import any Tool Palettes into that folder.

Similar Threads

  1. CP223-1: Trick Up Your Tool Palettes: How to Make Your Tool Palettes Do Even More!
    By Autodesk University in forum Customization and Programming
    Replies: 0
    Last Post: 2015-08-07, 05:17 PM
  2. Tool Palettes quit working
    By kberger in forum AutoCAD LT - General
    Replies: 3
    Last Post: 2011-10-14, 06:13 PM
  3. Tool Palettes not working
    By BCrouse in forum AutoCAD Customization
    Replies: 0
    Last Post: 2009-01-08, 04:13 PM
  4. Working with AutoCAD Profiles and Tool Palettes
    By Rico in forum AutoCAD Customization
    Replies: 3
    Last Post: 2006-10-28, 05:42 AM
  5. Replies: 2
    Last Post: 2006-10-25, 07:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts