View Full Version : Light Fixture from Revit

2009-04-02, 05:27 PM
How do you get rid of the "light intensity sphere" coming out of the light fixture?
The problem is when I tried to hide it in Navis, the light fixture itself is also hidden.

So the question is what's the best way to export the light fixture from Revit without including the "light intensity sphere"? (See attached PDF file)

Thanks in advance.

2009-04-02, 06:51 PM
i faced this problem and the only way i found was to hide the source in revit before exporting then choose the option in export that doesn;t export hidden elements.
maybe someone else knows a solution inside Navis

2009-04-02, 07:34 PM
We've seen this problem a few times--check these two threads:



2009-04-03, 06:58 PM
I tried your method, it works. Thanks a lot.

1.Select a light fixture
2.Click “Edit Family” on options bar
3.Click Settings > Family Category and Parameters
4.Uncheck the box next to “Light Source”
5.Load family back into project

But the thing is that This file is coming from the other consultant. Let's say I update the family this time. If he updates his model in the future, do I have redo these steps again? Or do I just save the family into a separate file, everytime when I receive the updated file from him, I just load the saved family into the project?

Thanks it advance.

2009-04-03, 07:18 PM
I definitely understand your problem. I typically go the route of just reducing the size of the light source to something negligible. If your consultant isn't averse, you could have them make that change for you so you don't have to deal with the problem.

Both of your solutions should work and I can see the pros and cons of each. You can manually change the light source to each light family and type in revit each time you get an update, but that takes too much time. You can save the families and reload them each time, but what of the new types created by your consultant?

Bottom line, it is probably best if they make the change for you, otherwise I would manually change it each time I get an update.

2009-04-03, 08:54 PM
Your brought up a good point.

I guess the best solution for now is to have the consultants notify us whether any new light fixture types have been added. At this stage of the project, I don't think there will be any new light fixtures. So I'll use your method and save the familes as a separate files. I'll load them into the updated file every time I receive from them.

Thanks once again. You've beee very helpful. I really appreciate that.

2009-04-20, 04:06 PM
Why don't you just hide the light source in Navisworks, I posted a search set here http://forums.augi.com/showthread.php?t=86518 then you don't have to edit their files externally.

2009-04-28, 03:11 PM
I noticed that in NavisWorks you can hide the light source if the DEFAULT light source definition is used in the Revit family, but there is a problem if you use a user-defined IES file for the light source. When you do that, it reads its geometry as a joined part of the light fixture itself, so if you were to hide it, it would hide the entire fixture. Anyone else see this problem?

2009-04-28, 04:38 PM
I just tried that and I actually get no light source geometry if an ies file is specified. There are some strange lines that seems to be from the light source, but I always have lines turned off.

2009-05-21, 04:47 PM
I am having this same problem. I am exporting a nwc from Revit and I have IES files specified. I cannot turn off just the light source in Navisworks. The light source is attached to fixture. Any solutions? I can't turn off the light source in the family because I need it for rendering purposes.

2009-05-21, 05:33 PM
So after trial and error I found a solution. When you export to Navisworks go into Navisworks settings/File Reader/Revit there is a check box that says "try and find missing materials". Make sure that box is NOT checked.

That will allow you to turn off the light source independent from the fixture. However, I do not know the ramifications of unchecking that box everywhere else in the project.

2009-06-03, 03:13 PM
I changed the "Light Source Symbol Size" in the Family Type Properties for each of my lights to 1" prior to exporting to Navisworks (it errored when I set it to 0). This removed the annoying yellow spheres and cones.

2009-06-03, 03:43 PM
If you are doing that than I don't believe your light rendering will work correctly. If that's the case you can just go into the family under "settings/family categories and parameters/" you can turn off light source all together.

2009-06-08, 05:58 PM
I turned off my light sources for all of my revit lights. When I exported this to Navisworks, no light sources. Good, right? Two issues occur from this...

When you try to render in Revit, no lights.
When you try to reactivate the light source the shape is reset to a generic tube which has nothing to do with the original configuration.

2009-06-08, 06:02 PM
You are correct, I only suggested this because the previous user is reducing the light source size which would result in incorrect rendering so you might as well turn it off altogether. If you follow the suggestion in my first post you can still use the rendering and turn off the light source in Navisworks.

2009-07-21, 07:01 AM
I have the same problem, so what I did... I have two types of lighting, one with the normal settings and one with the "Emit from line Length set to 1.0" ... before exporting to NW... I replace all my lighting with the light source turned off. This is easily done using the select all instances... so it's just switching the lighting family within the Revit. Hope this helps.