Results 1 to 8 of 8

Thread: attribute which is not assigned to block is not visible in xref

  1. #1
    Member
    Join Date
    2008-12
    Posts
    5
    Login to Give a bone
    0

    Unhappy attribute which is not assigned to block is not visible in xref

    Hello,

    Please help me as soon as possible.

    I have made one attribute with help of ATTDEF command. (Invisble is unchecked)

    I have not assigned it to block.

    When i xref this file to other file Attribute is not visible in that drawing. (All Layer is on and Unfreeze).

    please help me.

  2. #2
    Active Member
    Join Date
    2001-02
    Location
    Charlotte
    Posts
    89
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    Did you make sure all layers were on and thawed?
    if so, check attdisp variable.

  3. #3
    Administrator Ed Jobe's Avatar
    Join Date
    2000-11
    Location
    Turlock, CA
    Posts
    5,773
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    Is the att in ms? You won't see it if you put it in ps.
    C:> ED WORKING....

  4. #4
    Certified AUGI Addict jaberwok's Avatar
    Join Date
    2000-12
    Location
    0,0,0 The Origin
    Posts
    8,570
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    Attributes only work when part of a block though they should be visible.
    John B

    "You can't convince a believer of anything; for their belief is not based on evidence, it's based on a deep-seated need to believe." - Carl Sagan

  5. #5
    AUGI Director scott.wilcox's Avatar
    Join Date
    2015-11
    Location
    Edmonton, Alberta
    Posts
    990
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    Go back to the original dwg, create a block from that attribute, and reload the XREF. You should then see it
    Why draw straws? Just draw one straw and array it.

    Scott Wilcox - Edmonton, Alberta


  6. #6
    Certifiable AUGI Addict tedg's Avatar
    Join Date
    2005-06
    Location
    in the upper right corner
    Posts
    3,280
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    Yes as Scott mentioned above, you must make the "attribute defininitions" into a block.
    (I call them "raw attibutes" because they haven't been made into a block yet)

    Even though you can see the raw attributes in the xref file, they won't show up in the file you're bringing the xref into, until it's a block.
    Ted
    ____________________________________________________________________ ________________
    Windows 10
    AutoCAD 2018 - REVIT 2019 - Inventor Professional 2017 (when I can)

  7. #7
    Certifiable AUGI Addict irneb's Avatar
    Join Date
    2015-11
    Location
    Jo'burg SA
    Posts
    4,512
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    As mentioned AttDef's only become Attrbutes if used through blocks, not XRefs. So either place the AttDef inside a block in the xref, or in a Block in the current DWG.

    I'd also have liked the functionality you want, since this would make Title Blocks more easily used. You could attach the XRef inside the block in the current DWG to have it appear as if the Attributes are part of the XRef.
    Knowledge is proportional to experience, but wisdom is inversely proportional to ego!
    My little bit of "wisdom": Hind-sight is useless, unless used to improve the next forethought!

  8. #8
    Member
    Join Date
    2008-12
    Posts
    5
    Login to Give a bone
    0

    Default Re: attribute which is not assigned to block is not visible in xref

    thank you all for your valuable answers..

    but i still not get how i want.

    if somebody know how or i wish it is cover in new version... then it will great..

Similar Threads

  1. Replies: 13
    Last Post: 2012-09-18, 07:51 PM
  2. Block geometry is visible until block editor is opened.
    By 3ddraft in forum AutoCAD General
    Replies: 1
    Last Post: 2010-04-26, 11:47 AM
  3. Copy previous Block Attribute Value to next Block Attribute
    By CADfunk MC in forum VBA/COM Interop
    Replies: 8
    Last Post: 2009-02-27, 09:46 PM
  4. Objects not visible in drawing with xref.
    By neilcheshire in forum AutoCAD LT - General
    Replies: 4
    Last Post: 2007-06-07, 02:35 PM
  5. Block Attribute Manager Vs. Enhanced Attribute Editor
    By zoomharis in forum AutoCAD General
    Replies: 0
    Last Post: 2006-04-15, 11:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •