Results 1 to 10 of 10

Thread: Nested Detail Component - Always On Top?

  1. #1
    Member
    Join Date
    2007-11
    Posts
    37
    Login to Give a bone
    0

    Default Nested Detail Component - Always On Top?

    Revit 2010

    Is it normal that a nested detail component will always remain on top in the project? And yes, I've slammed the "send to back" a million times to no avail, so it's not an order issue.

    I draw filled regions or detail lines too and put "on top" and they stay behind the object.

    I guess another way of asking this question is will a nested detail component with a filled region or masked region override it's placement in the project?

    I can't remember if that is normal.

  2. #2
    Member
    Join Date
    2007-11
    Posts
    37
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    Okay, well this works just fine in Revit 2009. Lines/Masking region goes ahead or behind like it should.

    2010, Detail Components stay on top ALWAYS.

    Ideas?
    Attached Images Attached Images

  3. #3
    Member
    Join Date
    2007-11
    Posts
    37
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    Figured it out.

    I have no idea why it does this, but if you make a detail component "shared" it will not allow you to control the plane it "exists" on. It will always remain "on top" no matter what.

    Time to undo some stuff.

  4. #4
    Member
    Join Date
    2007-11
    Posts
    37
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    Well, it just occurred to me why this is stinks.

    I can't keynote individual pieces of the Detail Component, which was pretty awesome.

    That functionality is broken. I'll file a request I suppose.

    Does anyone have 2011 to confirm if this item is fixed?

    Simply nest two Detail Components together that are shared, see if you can change the order in project.

  5. #5
    All AUGI, all the time
    Join Date
    2006-08
    Posts
    636
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    i had similar issue just recently, if it works in 2009, broken in 2010, then can Autodesk fix it in 2011 or already fixed (hopefully)?

  6. #6
    Member
    Join Date
    2007-11
    Posts
    37
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    Joe - I got a response from the help desk and they have said that this issue is resolved in 2011, so that's good at least.

    Bad part is I just started a project in 2010 and we probably won't roll out 2011 until later this year.

  7. #7
    Member
    Join Date
    2006-01
    Location
    Halifax, Nova Scotia
    Posts
    16
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    I'm still having this issue with both 2011 and 2012. This makes nested detail components not usable for us. I have sent another support request off to Autodesk.

  8. #8
    Active Member Sweetshelby's Avatar
    Join Date
    2003-09
    Location
    ATL-GA
    Posts
    89
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    I am using 2012 Revit and after creating quite a few detail components this way and doing 3 details in our project and keynoting them we then realized we could not move back the shared detail components behind a break line. This really hurts because we needed them shared to do the keynotes.
    I had to go back and "save as" change the names, uncheck the shared box and reload them all and then change them in all the details. Now I have to also do text instead of keynotes. Pretty big issue.

    PLEASE!!! Get word to Autodesk to fix this issue ASAP!!

  9. #9
    100 Club
    Join Date
    2015-08
    Location
    Seattle, WA area
    Posts
    102
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    I know with masking regions in nested families it makes a big difference which work plane a masking region is placed upon. For instance; the issue I was facing were tables of various sizes with a nested chair object. In certain configurations the chairs would display correcly in relationship to the tables; ie the table mask that portion of the chairs under the edge of the table. However, in other configurations some chairs would work correctly while others did not.

    What I discovered was the table masking region needed a work plane that was associated with the table top. And I had to go into the chair nested family and assoicate the masking region there with the seat cushion of the chair. Again I used a reference plane to be certain that would work.

    So far so good. You might try the same approach. It would be interesting if that resolves the issue. I understand that need for using Keynotes. Although Note Blocks can work - a little more labor but do-able.

  10. #10
    Woo! Hoo! my 1st post
    Join Date
    2019-12
    Posts
    1
    Login to Give a bone
    0

    Default Re: Nested Detail Component - Always On Top?

    Here we are and Revit 2023 still has the same BIG ISSUE unsolved!!!
    Did anyone find a workaround for this issue?

Similar Threads

  1. 2012: Tagging a nested Detail Component
    By Duncan Lithgow in forum Revit Architecture - General
    Replies: 15
    Last Post: 2012-06-22, 02:28 PM
  2. nested detail component lineweight
    By cbaze in forum Revit Architecture - General
    Replies: 0
    Last Post: 2009-06-17, 07:33 PM
  3. detail component in nested profile family
    By cbaze in forum Revit Architecture - General
    Replies: 4
    Last Post: 2009-06-05, 09:50 AM
  4. Nested Detail Component won't display
    By sfaust in forum Revit Architecture - Families
    Replies: 2
    Last Post: 2008-09-17, 09:15 PM
  5. nested detail component
    By ford347 in forum Revit Architecture - Families
    Replies: 3
    Last Post: 2006-08-15, 01:37 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •