Results 1 to 6 of 6

Thread: unknown command error for simple commands

  1. #1
    Member
    Join Date
    2010-09
    Posts
    21
    Login to Give a bone
    0

    Default unknown command error for simple commands

    Hello everyone,
    i'm ITing an engineering office of about 20 pc's that run various versions of autocad (from 2006 to 2010).

    Last week it started occuring that basic commands like 'line','move','extend/trim' or 'quit' and 'plot', are not recognized. (oddly enough , 'circle' and 'polyline' ARE recognized)
    searching the net i came across this discussion:

    http://forums.autodesk.com/t5/AutoCA...ds/m-p/2716073

    but i'm not sure what is means by unloading express tools. and adding some .lsp files; how do you unload express tools? do you restart autocad? and what .lsp routines should one load afterwards? any? some specific?

    This week the problem has spread like a virus to other pc's too. So it feels like something is tampering with Autocad.
    additionally i see an acad.lsp file being created in every directory that a dwg file has been edited/created this past week.

    Has anyone seen this? is there a solution?

    I'm afraid reinstalling the program in 20 computers will not solve the issue if the acad.lsp is still there. BUT is it enough to delete the acad.lsp from each folder? will that solve the issue?

    Thank you for your help

  2. #2
    Certified AUGI Addict jaberwok's Avatar
    Join Date
    2000-12
    Location
    0,0,0 The Origin
    Posts
    8,569
    Login to Give a bone
    0

    Default Re: unknown command error for simple commands

    Ignore that thread - it sounds like the "acaddoc.lsp virus" (google it).
    Here is one of several threads that discuss it.
    John B

    "You can't convince a believer of anything; for their belief is not based on evidence, it's based on a deep-seated need to believe." - Carl Sagan

  3. #3
    Member
    Join Date
    2010-09
    Posts
    21
    Login to Give a bone
    0

    Default Re: unknown command error for simple commands

    Its not the acaddoc.lsp unfortunately.
    Got this virus a few months ago.
    Fixed it with a nice lsp routine I found.

    This time around its not acaddoc though...

  4. #4
    Administrator Opie's Avatar
    Join Date
    2002-01
    Location
    jUSt Here (a lot)
    Posts
    8,448
    Login to Give a bone
    0

    Default Re: unknown command error for simple commands

    AutoCAD loads the first acad.lsp or acaddoc.lsp it finds within the drawing directory or the Support File Search Paths. You need to track down where this file is initially being created and remove it. Search your drives for the two names above.
    If you have a technical question, please find the appropriate forum and ask it there.
    You will get a quicker response from your fellow AUGI members than if you sent it to me via a PM or email.
    jUSt

  5. #5
    Member
    Join Date
    2010-09
    Posts
    21
    Login to Give a bone
    0

    Default Re: unknown command error for simple commands

    well that did it.
    some acad.lsp files that i deleted in the users directories have solved the problem

    thanks!

  6. #6
    Certified AUGI Addict jaberwok's Avatar
    Join Date
    2000-12
    Location
    0,0,0 The Origin
    Posts
    8,569
    Login to Give a bone
    0

    Default Re: unknown command error for simple commands

    I'm glad you found it - now you need to figure out how it got into your system.
    John B

    "You can't convince a believer of anything; for their belief is not based on evidence, it's based on a deep-seated need to believe." - Carl Sagan

Similar Threads

  1. 2013: Multiple unknown commands
    By erikhenao32 in forum AutoCAD General
    Replies: 2
    Last Post: 2014-04-01, 11:10 PM
  2. AUTOCAD 2013 Error: _sheetset unknown command "sheet set"
    By omorah in forum AutoCAD Customization
    Replies: 3
    Last Post: 2012-06-18, 09:25 PM
  3. UNKNOWN COMMAND - VARIOUS COMMANDS
    By odwa.noah in forum AutoCAD General
    Replies: 12
    Last Post: 2010-11-05, 08:30 AM
  4. Unknown Command Error, but routine works?
    By Brian Benton in forum AutoLISP
    Replies: 2
    Last Post: 2006-10-13, 04:16 PM
  5. Replies: 4
    Last Post: 2006-02-03, 07:34 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •