I am using AutoCAD electrical, and every time I open a drawing created from one of my work's templates I get the follwoing message (note: the Civil department at my work does use Civil 3D, I have opened one of their drawings in "vanilla" AutoCAD 2011 but never in AutoCAD Electrical):

The drawing you have opened or referenced contains custom objects created by an unavailable ObjectARX application. You do not need the original applicationto display proxy representations of objects that were saved in the drawing. However many manufacturers, including Autodesk provide object enablers that alsoallow you to edit these custom objects.

Visit the AutoCAD Object Enabler Assistant web page to locate Autodesk object enablers or contact the software publisher about object enablers for other applications.

Note: If your computer has internet access verify that Check Web for Live Enablers is selected in the Options dialog box on the System tab to have AutoCAD automatically search the Live Enabler website for the appropriate object enabler. {I TRIED THIS}

Missing Application: AeccvBase 80
Product Desc: AutoCAD Civil 3D
Company: Autodesk, Inc.
WEB Address:
Total Number of Proxies: 2
Number of objects (no graphics): 2
Number of entries with no graphics: 0
Number of entities with bounding box graphics: 0
Number of entities with real graphics metafile: 0

Missing Application: AeccLand80
Product Desc: AutoCAD Civil 3D
Company: Autodesk, Inc.
WEB Address:
Total Number of Proxies: 283
Number of objects (no graphics): 283
Number of entries with no graphics: 0
Number of entities with bounding box graphics: 0
Number of entities with real graphics metafile: 0

Missing Application: AeccBuildingSite80
Product Desc: AutoCAD Civil 3D
Company: Autodesk, Inc.
WEB Address:
Total Number of Proxies: 2
Number of objects (no graphics): 2
Number of entries with no graphics: 0
Number of entities with bounding box graphics: 0
Number of entities with real graphics metafile: 0

Missing Application: AeccPlanProd80
Product Desc: AutoCAD Civil 3D
Company: Autodesk, Inc.
WEB Address:
Total Number of Proxies: 4
Number of objects (no graphics): 4
Number of entries with no graphics: 0
Number of entities with bounding box graphics: 0
Number of entities with real graphics metafile: 0

Proxy Graphics:
- Do not show proxy graphics
- Show proxy graphics
- Show proxy bounding box

It doesn't seem to make any difference which option I choose, so I just don't chose any and click OK, and the drawing seems fine, but having to click ok for every drawing is really getting annoying, especially when opening in batches.

Do I really have to go locate these Civil 3D enablers? I would rather try to remove whatever is looking for them.

I did try just opening an AutoCAD electrical template, saving it, and re-opening it. I did NOT get this message in that case.

Thanks for any help you can offer.