Results 1 to 4 of 4

Thread: Align Line Based Family to Host

  1. #1
    I could stop if I wanted to
    Join Date
    2010-04
    Location
    Gamehendge
    Posts
    281
    Login to Give a bone
    0

    Default Align Line Based Family to Host

    I am trying to model some snow rails on the eaves of my roof, but i'm having the hardest time installing them correctly. I have selected each roof face to host a line based family. they appear to snap in plan, but when i dimension the family so that each one is 1 foot from the roof edge, revit forces an arbitrary offset from the host surface. I've been struggling with this for an hour now, and im finding it infuriating. I could install these rails in about 15 mins in autocad, rhino, max, or sketchup. Revit attempts to simplify the modeling process too much.

  2. #2
    AUGI Addict
    Join Date
    2001-07
    Location
    Phoenix, AZ
    Posts
    1,003
    Login to Give a bone
    0

    Default Re: Align Line Based Family to Host

    Can you post the family?

  3. #3
    I could stop if I wanted to
    Join Date
    2010-04
    Location
    Gamehendge
    Posts
    281
    Login to Give a bone
    0

    Default Re: Align Line Based Family to Host

    Heres the family. it will snap to the host automatically, but it offsets itself automatically if you try to align with a ref plane or detail line

    just tried aligning in a test project, and it popped 0' 2 9/16" off the surface of the roof
    Attached Files Attached Files
    Last edited by csdg.dsgn; 2012-01-26 at 12:35 AM. Reason: performed a test. had similar results

  4. #4
    AUGI Addict
    Join Date
    2001-07
    Location
    Phoenix, AZ
    Posts
    1,003
    Login to Give a bone
    0

    Default Re: Align Line Based Family to Host

    Sorry. It appears to work correctly on this end.

    Try taking it into a new project (don't use a template to get rid of any variables that your template might be causing) and test it there.

Similar Threads

  1. Void in family cuts face based host?
    By ron.sanpedro in forum Revit Architecture - Families
    Replies: 6
    Last Post: 2018-02-23, 04:25 PM
  2. Line Based Family doesn't line up
    By Buckland in forum Revit MEP - Families
    Replies: 0
    Last Post: 2011-08-15, 10:55 PM
  3. Use Face Based Void Family to Cut Host Beam Family?
    By matt.fleming in forum Revit Structure - General
    Replies: 0
    Last Post: 2011-05-28, 01:53 AM
  4. line based family to align with wall?
    By jhendershot in forum Revit - Platform
    Replies: 0
    Last Post: 2010-05-14, 01:02 AM
  5. Replies: 0
    Last Post: 2008-11-11, 11:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •