Results 1 to 5 of 5

Thread: Export/Import from Revit "No Suitable Geometry Found".

  1. #1
    100 Club
    Join Date
    2008-03
    Posts
    158
    Login to Give a bone
    0

    Default Export/Import from Revit "No Suitable Geometry Found".

    Hi there,

    I'm newer to my company.
    But I'm fairly seasoned when it comes to both Revit and NavisWorks.
    I seem to have hit a dead end.
    I can't seem to export/import the Revit model into Navisworks.


    I've been tasked with upgrading, tidying and cleanup on a revit model from an older project.
    It was mostly used as a showcase and presentation model rather than for working drawings.
    My end goal is to have a .nwd for the boss to be able to show off to potential clients and fellow consultants.


    When I import the .rvt from Navisworks:
    The computer will churn through the file. When it has finished processing, the filename shows up in the Navisworks Project Tree, but no elements of the file come through.
    It's just the filename alone with no elements in the tree.
    Other .rvt files are working as intended.


    I have also tried the Revit NWC exporter plugin from AutoDesk.
    Somewhere along the way at exporting "X-# of 1000ish" elements, the export will crash out with an error message,
    "No Suitable Geometry Found".
    I have tried other .rvt files, they are working as intended.




    I have done some searching online and it seems other users found that Revit has an error when "Detail Level" in the view templates has been selected.
    I have actually gone and deleted all the view templates in the project. Unfortunately, the error still persists.


    I'm getting rather frustrated and I'm not sure what to do now.
    Boss is breathing down my neck.
    Any thoughts on how I can transfer the project piece-by-piece over to a new .rvt file and do test exports?
    Maybe there is a way I can do this slowly and test the exports as I go until the entire project has been transferred over.


    I'm hoping somebody might be able to offer up suggestions or a fix for this.

    thank you so much for your time.

  2. #2
    Member
    Join Date
    2006-04
    Posts
    4
    Login to Give a bone
    0

    Default Re: Export/Import from Revit "No Suitable Geometry Found".

    Quote Originally Posted by ronsarlo View Post
    Hi there,

    I'm newer to my company.
    But I'm fairly seasoned when it comes to both Revit and NavisWorks.
    I seem to have hit a dead end.
    I can't seem to export/import the Revit model into Navisworks.


    I've been tasked with upgrading, tidying and cleanup on a revit model from an older project.
    It was mostly used as a showcase and presentation model rather than for working drawings.
    My end goal is to have a .nwd for the boss to be able to show off to potential clients and fellow consultants.


    When I import the .rvt from Navisworks:
    The computer will churn through the file. When it has finished processing, the filename shows up in the Navisworks Project Tree, but no elements of the file come through.
    It's just the filename alone with no elements in the tree.
    Other .rvt files are working as intended.


    I have also tried the Revit NWC exporter plugin from AutoDesk.
    Somewhere along the way at exporting "X-# of 1000ish" elements, the export will crash out with an error message,
    "No Suitable Geometry Found".
    I have tried other .rvt files, they are working as intended.


    I have done some searching online and it seems other users found that Revit has an error when "Detail Level" in the view templates has been selected.
    I have actually gone and deleted all the view templates in the project. Unfortunately, the error still persists.


    I'm getting rather frustrated and I'm not sure what to do now.
    Boss is breathing down my neck.
    Any thoughts on how I can transfer the project piece-by-piece over to a new .rvt file and do test exports?
    Maybe there is a way I can do this slowly and test the exports as I go until the entire project has been transferred over.


    I'm hoping somebody might be able to offer up suggestions or a fix for this.

    thank you so much for your time.

    Your view probably has "View Template" applied still. This is a bug in exporter. Remove the template from the view for exporting.

  3. #3
    Super Moderator david_peterson's Avatar
    Join Date
    2002-09
    Location
    Madison, WI
    Posts
    5,622
    Login to Give a bone
    0

    Default Re: Export/Import from Revit "No Suitable Geometry Found".

    One other thing we found was a family that had no category. I believe it was something that was created in Sketchup and imported into the model.
    That could be another cause.
    Dave Peterson
    BIM Coordinator

    Acad - 2019 - Revit 2020 w/ BIM 360 - Navisworks - 3ds 2020 - Ensacpe - Lumion - Win 7 64 - i7-8086K 4.0GHz 32GB Ram - Nvidia Quadro P2000
    "The more you know, the less you know, because the more you know you don't know". --M. Lin

  4. #4
    Active Member
    Join Date
    2009-06
    Posts
    91
    Login to Give a bone
    0

    Default Re: Export/Import from Revit "No Suitable Geometry Found".

    Does anyone else have experience sorting through this problem? I have about 13 models that the first 3 are giving me this error. I know I had the problem months ago when I did the last floor coordination, but can't remember how I fixed it.
    David Moody
    LEED AP
    Autodesk Revit Certified Professional
    Soon to be Registered Architect
    BIM Coordinator/Revit Implementation Specialist


    The Revit Life

  5. #5
    Active Member
    Join Date
    2009-06
    Posts
    91
    Login to Give a bone
    0

    Default Re: Export/Import from Revit "No Suitable Geometry Found".

    Quote Originally Posted by dmoodydesign View Post
    Does anyone else have experience sorting through this problem? I have about 13 models that the first 3 are giving me this error. I know I had the problem months ago when I did the last floor coordination, but can't remember how I fixed it.
    Solved my own problem. Previously I was able to make another 3d View and this worked. Today, I just unloaded all the Revit references and was good to go. Hope this helps someone else.
    David Moody
    LEED AP
    Autodesk Revit Certified Professional
    Soon to be Registered Architect
    BIM Coordinator/Revit Implementation Specialist


    The Revit Life

Similar Threads

  1. 2015: Issues with NWC Exporter (Revit) "no suitable geometry found"
    By mit81 in forum NavisWorks - General
    Replies: 2
    Last Post: 2015-06-05, 06:34 PM
  2. 2014: Revit novice; Revit link to rvt file has "Import Geometry Not Visible" error
    By stircrazy in forum Revit Architecture - General
    Replies: 0
    Last Post: 2014-01-10, 01:28 AM
  3. XREF "Saved Path" to "Found at" location
    By cadmancando in forum AutoLISP
    Replies: 1
    Last Post: 2012-01-18, 03:54 PM
  4. An "all-at-once" option for "Join Geometry"
    By IanR in forum Revit Architecture - Wish List
    Replies: 0
    Last Post: 2009-02-01, 07:12 PM
  5. Replies: 3
    Last Post: 2007-10-23, 09:06 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •