See the top rated post in this thread. Click here

Results 1 to 7 of 7

Thread: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

  1. #1
    Member
    Join Date
    2007-11
    Location
    UK
    Posts
    20
    Login to Give a bone
    0

    Default How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    These outlines of pipework and cable trays show with a thick dashed line underlaying the standard object outline IF the view is set to Discipline=Coordination AND Show Hidden Lines=ALL

    In all other views the lines are correct.

    Revit Hidden Line Problem 2016.pdf

    Ideally the thick dashed lines need to be changed to a thin line setting so it is not so obvious, or to be switched off completely in the view.
    I have not been able to find where the settings are for this thick dashed line.
    In addition, I need to 'Show Hidden Lines=All' to be on to show hidden elements like connections and grilles on the ductwork underside.

    Has anyone seen this or can offer a solution to make this work correctly?

  2. #2
    Member
    Join Date
    2007-11
    Location
    UK
    Posts
    20
    Login to Give a bone
    0

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    After many hours testing a workaround has been established.

    The line weight 16 has been set to 0.025mm. The Piping Systems and Duct Systems Type Properties have been set with a Graphic Override Weight=16.
    This makes the linework thin and although the 'dashed line' is still there it is very thin and not visible once plotted.
    If the line weight is set to 1 then the dashed line is still thicker than the main line. Not sure why.

    This is somewhat protracted as each 'system' needs to be set, however it achieves what is needed.

  3. #3
    Member kubsix's Avatar
    Join Date
    2007-08
    Location
    Quad Cities, Illinois
    Posts
    44
    Login to Give a bone
    0

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    Looks like you may have another view set as an Underlay. Check that the view's "Underlay" parameter is set to None.

    The line weight of hidden lines are defined by they line style chosen under Manage > MEP Settings > Mechanical/Electrical Settings. <Hidden> is the default. The weight of line styles are defined under Manage > Additional Settings > Line Styles.

  4. #4
    Member
    Join Date
    2007-11
    Location
    UK
    Posts
    20
    Login to Give a bone
    0

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    Thanks for the reply. The underlay is needed for this project to show the beams overhead, but it does not affect the lines at all.

    The line settings you mentioned would make sense but changes do not affect the thick dashed lines. That was the first thing I tried.

    What is strange is that the 'dashed line' is only minimized by setting the graphics override to a line weight of 0.025mm. The dash is still there but is not obvious.
    If the override weight is changed to 1 or more then the dash is back. It is not there if the view is not set to 'Show Hidden Lines = All'

    It's possible that the setting for the hidden dashed line is an internal parameter and is not editable.

  5. #5
    Member kubsix's Avatar
    Join Date
    2007-08
    Location
    Quad Cities, Illinois
    Posts
    44
    Login to Give a bone
    1

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    Diving deeper...you're right Mechanical settings and the <Hidden> line styles are not controlling those dashed lines. What I believe you are seeing is actually the inside wall of the pipe. This is revealed when setting the view's Show Hidden Lines to All with the view's Discipline set to Coordination.

    To control the dashed line you'll need to change....get ready for this....the WALLS > Hidden lines sub-category. Oh my

    I hadn't seen what Coordination w/ All Hidden lines displayed before now. Interesting stuff. I just assumed that the "All" Show Hidden Lines setting just turned backed on the hidden lines that Coordination discipline turned off. Nope. It displays the inside wall.

  6. #6
    Member
    Join Date
    2007-11
    Location
    UK
    Posts
    20
    Login to Give a bone
    0

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    Many thanks for that and I would not have looked at the walls settings.
    This now also fixes the cable trays as they do not have a 'system' for my bodge to work.

    It does seem that the pipe inner line is classed as a wall. So probably also the cable trays and the ducts.

    Just done some testing and the dashed line does not represent the pipe's inner wall.
    A new pipe size of 299mm OD and 99mm ID was created, so the wall thickness should be 100mm. The dashed line is still on the outer edge.

    Strange setup?

    Attached Revit file for testing:
    Attached Files Attached Files
    Last edited by mike.154133; 2016-04-06 at 10:08 AM. Reason: Updated info

  7. #7
    Member kubsix's Avatar
    Join Date
    2007-08
    Location
    Quad Cities, Illinois
    Posts
    44
    Login to Give a bone
    0

    Default Re: How do I remove or change the Thick Dashed Hidden Lines when Discipline=Coordination AND Show Hidden Lines=ALL

    Quote Originally Posted by mike.154133 View Post
    Just done some testing and the dashed line does not represent the pipe's inner wall.
    Yep. Agree. But whatever it is it is revealed by the Show Hidden Lines set to All and it's visibility is controlled by the Wall > Hidden Line subcategory.

    The common practice for Mech and Elect views is:
    Discipline: Plumbing, Mechanical, or Electrical
    Graphic Display Option: Hidden lines
    Show Hidden Lines: By Discipline.

    I'd recommend starting with that and adjusting visibility from there to achieve what you need. It will be more logical.

    All that the Coordination Discipline really does is turn off the hidden lines and normalize all categories.
    The Show Hidden Lines parameter is mainly intended for architectural and structural views.

Similar Threads

  1. Replies: 3
    Last Post: 2011-01-31, 04:15 AM
  2. hidden lines showing as dashed lines
    By tomcarver in forum AutoCAD 3D (2007 and above)
    Replies: 2
    Last Post: 2010-09-26, 09:09 AM
  3. Replies: 3
    Last Post: 2007-03-25, 02:19 PM
  4. Dashed (Hidden) Lines in Family Editor
    By gordgraff in forum Revit Architecture - Families
    Replies: 3
    Last Post: 2005-04-22, 02:13 AM
  5. Hidden and Dashed Lines
    By IanR in forum ACA General
    Replies: 2
    Last Post: 2004-07-07, 02:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •