Results 1 to 1 of 1

Thread: keynote block in mleaderstyle goes wonky

  1. #1
    Certifiable AUGI Addict cadtag's Avatar
    Join Date
    2000-12
    Location
    Cairo - no, not Illinois
    Posts
    4,751
    Login to Give a bone
    0

    Default keynote block in mleaderstyle goes wonky

    This is only happening in few drawings in a set, not every one.

    background is that I've been using the same mleader style and keynote block for months without issue. The blcok is _TagHexagon, and is defined in BEdit as a pline Hexagon with a single attribute. The Attdef and Pline Hex are created on layer 0 with color byblock. A solid hatch with TrueColor 255,255,255 is underneath both the hexagon and attdef.

    The mleaderstyle is pretty basic, and has the _Tag_Hexagon block set as the content.

    Suddenly, with no apparent cause, the block in existing and new mleaders swaps displayed colors, with the hexagon appearing as 255,255,255, and the background hatch showing up with the current layer color. the attribute stays the correct displayed color. son on my annotation layer, with color red, I end up with a red leader line and arrowhead, white hex, red text on a red background. Kinda hard to the text in the block that way.

    Inserting the same block by itself, rather than as an mleader component, and it shows up as expected. I'm open to suggestions, - this is painful and naturally it's a friday deadline

    keynotes.PNG

    update info- that same block displays properly in the table, and the drawing plots correctly -- it's just the on-screen display in a few drawings that's fubar'ed. Audit, purge redefining the block and mleader makes no difference.
    Last edited by cadtag; 2018-03-30 at 02:02 PM.
    Real pirates wear silk suits & ties, and write EULAs
    The only thing more dangerous to the liberty of a free people than big government, is big business.

    Toward a Sustainable Water Future: Visions for 2050 http://ascelibrary.org/doi/book/10.1061/9780784412077

Similar Threads

  1. 2016: MLEADERSTYLE - USING BLOCK FOR MTEXT HAS MISBEHAVING ATTRIBUTE
    By mmiles in forum AutoCAD Annotation
    Replies: 3
    Last Post: 2019-01-04, 06:21 PM
  2. 2016: MLEADERSTYLE w/ CONTENT SET TO BLOCK & TOOL PALETTES
    By mmiles in forum AutoCAD Annotation
    Replies: 3
    Last Post: 2016-03-15, 08:24 PM
  3. Keynote Block, can't sort by type?
    By patricks in forum Revit Architecture - General
    Replies: 7
    Last Post: 2009-10-29, 04:45 PM
  4. osnaps not snapping to block in mleaderstyle
    By CAD Brad in forum AutoCAD General
    Replies: 3
    Last Post: 2008-08-21, 03:39 PM
  5. Keynote vs Note Block
    By dalewww in forum Revit Architecture - General
    Replies: 11
    Last Post: 2007-06-11, 12:36 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •