Results 1 to 2 of 2

Thread: XREF Not Found After Annotation Adjustments Made in Base Drawing

  1. #1
    Login to Give a bone
    0

    Exclamation XREF Not Found After Annotation Adjustments Made in Base Drawing

    I have a base drawing.


    I XREF it into a new drawing where I add annotative objects (text, dimensions, leaders).


    I XREF the annotated version into a new drawing to be combined with other xrefd drawings for plotting.


    When I return to the drawing of its annotated version and make modification to the annotation objects and save, I am prompted to "Reload Updated Xrefs" on the "combined xref drawings file".


    Upon "reloading", the base drawing disappears and XREF dialog box says that the file cannot be found. (refer to Pic1)


    I have relocated the path and even tried updating the path manually. It doesn't matter what I enter, it simply will not locate the file.


    SO...


    To make things more interesting, I tried copy/pasting(made a duplicate) the combined xref drawings file.


    I opened the copy, and voila, for some reason all my xref'd drawings appear.


    This is not an ideal work around.


    I'm still stuck with some issue that may be related, where one of my layouts (each layout is a different plotter size w/ accompanied viewports at different scales) does not correctly scale the annotative text, where as all my other layouts, and their viewports at different scales, display the correct scale of the annotative objects. (refer to Pic 2 & 3)


    I'm not sure what to do.


    PIC 1
    error1.png

    PIC2 CORRECT ANNOTATIVE OBJECT SCALE INSIDE VIEWPORT FOR A LAYOUT
    error2.png

    PIC 3 WRONG ANNOTATIVE OBJECT SCALE INSIDE VIEWPORT FOR A LAYOUT
    error3.png

  2. #2
    Certifiable AUGI Addict tedg's Avatar
    Join Date
    2005-06
    Location
    in the upper right corner
    Posts
    3,179
    Login to Give a bone
    0

    Default Re: XREF Not Found After Annotation Adjustments Made in Base Drawing

    Is there any way you could upload sample drawings files? It would help to troubleshoot.

    For your first problem..
    My first guess would be to check your paths, relative vs absolute etc, also check for Attach vs Overlay.
    It sounds like you have a nested xref scenario, where "Base.dwg" is referenced into "Annotation.dwg", and "Annotation and Base" dwg's are xreffed into your sheet/Layout drawings?
    If that is the case, "Base.dwg" needs to be attached (not overlaid) into "Annoation.dwg" (maybe you know this already).

    An alternative for this is to use "overlay" for everything, which means you would have the "Base" xreffed (overlay) into your annotation dwg for reference (to add your annotation on top of), and also xreffed (overlay) into the sheet drawings.
    you would never "attach" an xref in each of those, it would be circular xreffing which is bad.

    For your second problem..
    I would check the available annotation scales for all your annotation objects, make sure you have ALL the scales you want and they match your viewport scales EXACTLY.
    Ted
    ____________________________________________________________________ ________________
    Windows 7 Professional
    AutoCAD 2018 - REVIT 2019 - Inventor Professional 2017 (when I can)

Similar Threads

  1. LISP for Reloading Xref Not Found or Unrefered
    By ELIANDEFI in forum AutoLISP
    Replies: 3
    Last Post: 2015-03-26, 11:56 AM
  2. 2012: Make a New Sheet, Titleblock Comes in as Xref Not Found
    By CADKitty in forum AutoCAD Sheet Set Manager
    Replies: 1
    Last Post: 2012-12-19, 06:49 PM
  3. Replies: 1
    Last Post: 2012-06-06, 12:29 AM
  4. xref's no found in folder
    By rhayes.99001 in forum ACA General
    Replies: 3
    Last Post: 2007-05-26, 01:56 AM
  5. Xref in correct path not found
    By sifuentes in forum AutoCAD General
    Replies: 2
    Last Post: 2005-09-09, 05:59 PM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •