Results 1 to 5 of 5

Thread: Font styles using "archstyl.shx" display as block text in ONE project ONLY...

  1. #1
    100 Club
    Join Date
    2006-12
    Posts
    104
    Login to Give a bone
    0

    Question Font styles using "archstyl.shx" display as block text in ONE project ONLY...

    A real head-scratcher here...

    I use a style in much of my work that makes use of the "archstyl.shx" font, which is a hand-lettering font not standard in Autocad. I depend on this font extensively, due to its unique way of displaying fractions. The font file exists in all my search paths, and never had I had a problem with it, except in this one particular project, whose master DWG and all XREF files were provided by my client.

    In the master file, and in any of the xref files, any text I create using this font appears as simple block letters. Additionally, any block I insert from my library containing this font appears incorrectly. I have searched for any font or styles of the same name in the client-supplied files which might be overriding my own, but find none. Once I have inserted a block, or created a text in the suspect files, the proper style name and archstyl.shx font do appear in the Styles dialog, so I know Autocad is finding it, but all attempts to get it to display properly have failed.

    I have tried creating new and unique styles within the drawings, using the archstyl.shx font, with the same results. Remember that this behavior appears ONLY in THIS particular group of DWG files, so I'm thinking there must be some setting within those files, and saved with them, that is causing this. Other styles and fonts within the same drawing group appear as they should.

    One other thing... This is not confined to Autocad 2019, as I have run the files on a 2018 install, and it does the same thing.

    Anyone have any ideas? I've burned out too many brain cells trying to get my head around this one...

  2. #2
    Certifiable AUGI Addict tedg's Avatar
    Join Date
    2005-06
    Location
    in the upper right corner
    Posts
    3,179
    Login to Give a bone
    0

    Default Re: Font styles using "archstyl.shx" display as block text in ONE project ONLY...

    That is odd.

    I assume you are not using the OOTB style name: "Standard" with the "archstyle.shx" font assigned to it in all your instances?
    Or any other shared named styles between yours and theirs?
    Because theirs would override yours when brought in to their files.

    What happens if you have something you created with a new style using archstyle.shx in their file (which doesn't appear correctly and you mention) and copy it into your file?
    Does it appear correctly in your file?
    Ted
    ____________________________________________________________________ ________________
    Windows 7 Professional
    AutoCAD 2018 - REVIT 2019 - Inventor Professional 2017 (when I can)

  3. #3
    100 Club
    Join Date
    2006-12
    Posts
    104
    Login to Give a bone
    0

    Default Re: Font styles using "archstyl.shx" display as block text in ONE project ONLY...

    Quote Originally Posted by tedg View Post
    That is odd.

    I assume you are not using the OOTB style name: "Standard" with the "archstyle.shx" font assigned to it in all your instances?
    Or any other shared named styles between yours and theirs?
    Because theirs would override yours when brought in to their files.

    What happens if you have something you created with a new style using archstyle.shx in their file (which doesn't appear correctly and you mention) and copy it into your file?
    Does it appear correctly in your file?
    The style I'm using is named "MSNOTE", so "Standard" is not the problem.

    No other shared style names...

    If I create mtext or text using the archstyl.shx font, and then insert into a completely unrelated drawing elsewhere in my archives, it displays as block text, regardless of whether I use the clipboard or create a wblock and insert it. I notice the command line reads "Substituting simplex.shx for archstyle.shx", even though my folders and search paths are littered with copies of archstyl.shx...

    Also interesting to note is that the unwanted block text in the MSNOTE style does adopt the size, width and other properties characteristic of MSNOTE, just not the font...

    Also of note is that, once any drawing in this project group is opened and a concurrent, but unrelated, drawing from another project is opened, the MSNOTE text in THAT drawing displays incorrectly, whether the suspect drawing is kept open or not. And this font will continue to display incorrectly in ANY drawing opened during the drawing session, but will return to normal if Autocad is closed, and then restarted, up until I open one from the "toxic" project. Apparently, these files are changing a setting within Autocad that is saved as long as the session is open.

    Weird enough yet?

  4. #4
    Certifiable AUGI Addict tedg's Avatar
    Join Date
    2005-06
    Location
    in the upper right corner
    Posts
    3,179
    Login to Give a bone
    0

    Default Re: Font styles using "archstyl.shx" display as block text in ONE project ONLY...

    I don't know a lot about "imposed standards" but that is what it sounds like.
    There is a setting (or settings) somewhere assigned to this project that is forcing standards on all the drawings.

    I really don't know what I'm talking about (yet) but that's what it sounds like.
    I know that's a thing.

    [edit]
    If you type "standards" is there a DWS file assigned to the project/dwgs?
    If so and under settings there is an option to select for "Automatically fix non-standard properties"
    So if that's it, the DWS that is assigned could be "fixing" those fonts for you.
    Last edited by tedg; 2019-04-08 at 01:39 PM. Reason: found some Standard info
    Ted
    ____________________________________________________________________ ________________
    Windows 7 Professional
    AutoCAD 2018 - REVIT 2019 - Inventor Professional 2017 (when I can)

  5. #5
    100 Club
    Join Date
    2006-12
    Posts
    104
    Login to Give a bone
    0

    Default Re: Font styles using "archstyl.shx" display as block text in ONE project ONLY...

    Quote Originally Posted by tedg View Post
    If you type "standards" is there a DWS file assigned to the project/dwgs?
    If so and under settings there is an option to select for "Automatically fix non-standard properties"
    So if that's it, the DWS that is assigned could be "fixing" those fonts for you.
    I wish this were the problem, but there is no DWS file attached to these drawings (totally blank in the "Standards" dialog).

Similar Threads

  1. Korean SHX font ngsw.shx
    By cordination in forum CAD Management - General
    Replies: 2
    Last Post: 2009-04-03, 10:59 PM
  2. Converting SHX Font to True Type Font
    By dortega4269 in forum Revit Structure - General
    Replies: 1
    Last Post: 2006-09-01, 05:19 PM
  3. archstyl font not displaying correctly
    By .chad in forum ACA General
    Replies: 3
    Last Post: 2006-08-23, 04:59 PM
  4. Font problem - Simplex.shx text "substituting" with Sans Serif
    By msanders.85217 in forum AutoCAD General
    Replies: 2
    Last Post: 2005-08-29, 03:40 PM
  5. Replies: 5
    Last Post: 2005-01-04, 07:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •