Results 1 to 5 of 5

Thread: AutoCAD Architecture Detail Components not working after Windows 11 Update

  1. #1
    Member
    Join Date
    2014-09
    Posts
    5
    Login to Give a bone
    0

    Exclamation AutoCAD Architecture Detail Components not working after Windows 11 Update

    At least 2 versions are broken. I get an error:

    Cannot open database C:\....AecDtlComponents(US).mdb

    Unable to cast COM object of type.... This operation failed because the QueryInterface call on the COM component for the interface with IID... failed due to the following error: No such interface supported (Exception from HRRESULT: 0X80004002 (E_NOINTERFACE))

    Any tips?

  2. #2
    Administrator Ed Jobe's Avatar
    Join Date
    2000-11
    Location
    Turlock, CA
    Posts
    5,947
    Login to Give a bone
    0

    Default Re: AutoCAD Architecture Detail Components not working after Windows 11 Update

    No doubt that 2020 used 32 bit to talk to mdb and Windows 11 doesn't have that component anymore, relying on 64 bit Office components. What version on Office do you have installed? According to Autodesk, Windows 11 support starts with 2021. You might search for a Microsoft solution for 32 but oledb access.
    C:> ED WORKING....

  3. #3
    Member
    Join Date
    2014-09
    Posts
    5
    Login to Give a bone
    0

    Default Re: AutoCAD Architecture Detail Components not working after Windows 11 Update

    Quote Originally Posted by Ed Jobe View Post
    No doubt that 2020 used 32 bit to talk to mdb and Windows 11 doesn't have that component anymore, relying on 64 bit Office components. What version on Office do you have installed? According to Autodesk, Windows 11 support starts with 2021. You might search for a Microsoft solution for 32 but oledb access.
    Thanks, I just tried installing the Microsoft Access Database Engine 32bit and it won't let me install it because I have 64 bit installed. It might be more effort to fix this than to update at this point, but the Windows 11 update worked fine on my laptop.

    - - - Updated - - -

    Quote Originally Posted by Peter1232 View Post
    Thanks, I just tried installing the Microsoft Access Database Engine 32bit and it won't let me install it because I have 64 bit installed. It might be more effort to fix this than to update at this point, but the Windows 11 update worked fine on my laptop.
    Sorry for the double post... would this work?

    https://support.microsoft.com/en-us/...e-46cbb9d730c7

  4. #4
    Administrator Ed Jobe's Avatar
    Join Date
    2000-11
    Location
    Turlock, CA
    Posts
    5,947
    Login to Give a bone
    0

    Default Re: AutoCAD Architecture Detail Components not working after Windows 11 Update

    I don't believe that you can have 64 bit version of Office and use the 32 bit driver at the same time. You have to choose one or the other.

    Quote Originally Posted by Peter1232 View Post
    At least 2 versions are broken.
    Is there a reason that you don't upgrade AutoCAD? Are you trying to keep multiple versions working?
    C:> ED WORKING....

  5. #5
    Member
    Join Date
    2014-09
    Posts
    5
    Login to Give a bone
    0

    Default Re: AutoCAD Architecture Detail Components not working after Windows 11 Update

    Quote Originally Posted by Ed Jobe View Post
    I don't believe that you can have 64 bit version of Office and use the 32 bit driver at the same time. You have to choose one or the other.


    Is there a reason that you don't upgrade AutoCAD? Are you trying to keep multiple versions working?
    I have a custom setup, with toolbars, and it is a pain to upgrade.

    The problem seems to have been fixed by installing AutoCAD Architecture 2022. The older versions work now.

Similar Threads

  1. 2015: Palette Display problem after recent Windows 10 Annversary Update
    By dennis.moyes in forum AutoCAD General
    Replies: 1
    Last Post: 2016-09-22, 06:42 PM
  2. Replies: 0
    Last Post: 2012-10-22, 03:43 PM
  3. Repeating detail - can't use a detail with other nested detail components?
    By patricks in forum Revit Architecture - Families
    Replies: 4
    Last Post: 2011-11-12, 03:35 AM
  4. Replies: 6
    Last Post: 2011-07-07, 08:25 PM
  5. Windows XP - After Windows update, "User32.DLL Relocated" error on startup
    By sinc in forum Operating Systems
    Replies: 2
    Last Post: 2007-04-09, 02:45 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •