See the top rated post in this thread. Click here

Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Hatch Pattern Palette Locking Up in ACAD 2007

  1. #1
    Active Member csorensen's Avatar
    Join Date
    2005-04
    Posts
    71
    Login to Give a bone
    0

    Unhappy Hatch Pattern Palette Locking Up in ACAD 2007

    When I try to insert a hatch (from the Hatch and Gradient Dialog box) I select "..." (Hatch Pattern Palette) this will lock up ACAD every time. Is there a way to fix this ? Is this a bug ?

  2. #2
    BIM/VDC Management Brian Myers's Avatar
    Join Date
    2003-02
    Location
    St Louis, Missouri
    Posts
    1,819
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by csorensen
    When I try to insert a hatch (from the Hatch and Gradient Dialog box) I select "..." (Hatch Pattern Palette) this will lock up ACAD every time. Is there a way to fix this ? Is this a bug ?
    It's not a bug, it's working fine for me...

    Do you have a custom hatch you are trying to bring in? Just trying to decide if this is an "installation" issue or perhaps an issue with it not being able to process one of your hatches...
    Brian Myers
    Sr Digital Delivery Lead | BIM Management | Author
    Visit my LinkedIn Profile for more information.

  3. #3
    Active Member csorensen's Avatar
    Join Date
    2005-04
    Posts
    71
    Login to Give a bone
    1

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by Dilbert
    It's not a bug, it's working fine for me...

    Do you have a custom hatch you are trying to bring in? Just trying to decide if this is an "installation" issue or perhaps an issue with it not being able to process one of your hatches...
    We have a custom hatch added to the ACAD.PAT. It worked on the previous versions. I deleted the one we customized and replaced it with the new ACAD.PAT from ACAD 2007. But, that didn't work either. Checked all support paths. I think we'll try a re-install.

  4. #4
    BIM/VDC Management Brian Myers's Avatar
    Join Date
    2003-02
    Location
    St Louis, Missouri
    Posts
    1,819
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    ... yes, that would have been my next advice... if it still doesn't work then it's likely something so far undocumented...
    Brian Myers
    Sr Digital Delivery Lead | BIM Management | Author
    Visit my LinkedIn Profile for more information.

  5. #5
    Woo! Hoo! my 1st post smorris.107492's Avatar
    Join Date
    2006-03
    Location
    Blair, Nebraska
    Posts
    1
    Login to Give a bone
    2

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    I work with the poster that posted this problem.


    As some follow up, after a re-install it worked fine. I then copied the pattern info for our custom patterns into a 'clean' copy of the 2007 acad.pat. This also worked just fine.


    So the problem is 'solved' and 2007 is working fine again. However if I copy the acad.pat file we have used for several years into the 'support' directory and replace the new one I made. It will crash again.


    I am not sure how or why, or what may have changed with the .pat file, but it seems something has changed. A file that works just fine in 2006 and previous, will crash 2007.

  6. #6
    AUGI Addict .T.'s Avatar
    Join Date
    2000-12
    Location
    Lost
    Posts
    1,473
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by smorris.107492
    I work with the poster that posted this problem.


    As some follow up, after a re-install it worked fine. I then copied the pattern info for our custom patterns into a 'clean' copy of the 2007 acad.pat. This also worked just fine.


    So the problem is 'solved' and 2007 is working fine again. However if I copy the acad.pat file we have used for several years into the 'support' directory and replace the new one I made. It will crash again.


    I am not sure how or why, or what may have changed with the .pat file, but it seems something has changed. A file that works just fine in 2006 and previous, will crash 2007.
    Just for curiosity's sake, could you post the two files so we could compare them? Maybe there's a space, tab or some other minor difference somewhere that's causing the problem. I think it would benifit the group if we found the problem and a way to easily fix it.
    Tim Creary
    S&D
    DILLIGAF

  7. #7
    Active Member csorensen's Avatar
    Join Date
    2005-04
    Posts
    71
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by timcreary
    Just for curiosity's sake, could you post the two files so we could compare them? Maybe there's a space, tab or some other minor difference somewhere that's causing the problem. I think it would benifit the group if we found the problem and a way to easily fix it.
    I attached the hatch pattern files. Acad06 is the file we've been using for years except until now. Acad07 is the one that works after the re-install.

  8. #8
    Active Member csorensen's Avatar
    Join Date
    2005-04
    Posts
    71
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by csorensen
    I attached the hatch pattern files. Acad06 is the file we've been using for years except until now. Acad07 is the one that works after the re-install.
    I noticed the attchments didn't show up. Does the attach files work on .pat files or do I need to do something different.

  9. #9
    Active Member csorensen's Avatar
    Join Date
    2005-04
    Posts
    71
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    Quote Originally Posted by csorensen
    I noticed the attchments didn't show up. Does the attach files work on .pat files or do I need to do something different.
    Try this !!!
    Attached Files Attached Files

  10. #10
    I could stop if I wanted to hugh.69031's Avatar
    Join Date
    2016-01
    Location
    Melbourne, Australia
    Posts
    359
    Login to Give a bone
    0

    Default Re: Hatch Pattern Palette Locking Up in ACAD 2007

    It's possible that the second copy of EXP-MTL in ACAD06.PAT is causing problems as some of its defining lines are terminated with linefeed (LF) characters only and lack carriage return (CR)characters that are normally present in MSDOS text files where lines are normally terminated with a CR/LF pair.

    I suspect simply deleting that second copy from the end of the file will fix things by using the earlier EXP-MTL pattern (terminated throughout with CRLF). Why 2007 and 2006 should treat the file differently I'll have to leave to others.

    BTW ACAD07.PAT contains metricated patterns as if it was ACADISO.PAT


    hth
    Hugh Adamson
    www.cadro.com.au/hatchkit/

Page 1 of 2 12 LastLast

Similar Threads

  1. 2015: End of Hatch Palette Freezes Acad
    By anuttall695934 in forum AutoCAD General
    Replies: 1
    Last Post: 2015-03-28, 02:42 PM
  2. Hatch Problems Acad 2008&2007
    By basement_boat in forum AutoCAD General
    Replies: 3
    Last Post: 2007-09-17, 10:27 AM
  3. Get Hatch Pattern Palette Custom Tab to show up
    By desiree.ball in forum AutoCAD General
    Replies: 4
    Last Post: 2007-03-29, 06:20 PM
  4. COPY and MOVE locking up ACAD 2007
    By frankowen2 in forum AutoCAD General
    Replies: 1
    Last Post: 2006-04-20, 04:31 PM
  5. Using ADT 04 hatch pattern file in ACAD 05
    By cgerhardt in forum AutoCAD Customization
    Replies: 5
    Last Post: 2006-01-14, 01:47 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •