Results 1 to 9 of 9

Thread: Custom menus & lisp not always loading

  1. #1
    I could stop if I wanted to
    Join Date
    2005-12
    Location
    Hartford, CT
    Posts
    394
    Login to Give a bone
    0

    Default Custom menus & lisp not always loading

    I have set up my compant standard enterprise CUI that way I want it, and placed it on a network share. When I open AutoCAD the CUI and all the customization I have created loads just the way I want it. But if I close that drawing, and then open another it is hit or miss. Sometimes my custom menus and lisp rourines load, sometimes they don't.

    In the AutoCAD options I have turned on the option to re-load lisp files for each drawing.

  2. #2
    The Silent Type RobertB's Avatar
    Join Date
    2000-01
    Location
    Seattle WA USA
    Posts
    5,859
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by tim.101799
    In the AutoCAD options I have turned on the option to re-load lisp files for each drawing.
    What option is that? If you checked the option for "Load acad.lsp with every drawing", that is not doing what you think it is. That is a legacy option that should only be used for lazy firms that had R14 or earlier customizations. AcadDoc.lsp (or a cui's .mnl file) should be used to load customizations in every drawing, and that happens automatically. So uncheck that option, so you have the ability to load code only when AutoCAD starts, which is what Acad.lsp has been used for since AutoCAD 2000.

    Now, about your real issue... how reliable is your network? Does the problem go away if your files are local?

  3. #3
    I could stop if I wanted to
    Join Date
    2005-12
    Location
    Hartford, CT
    Posts
    394
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by RobertB
    What option is that? If you checked the option for "Load acad.lsp with every drawing", that is not doing what you think it is. That is a legacy option that should only be used for lazy firms that had R14 or earlier customizations. AcadDoc.lsp (or a cui's .mnl file) should be used to load customizations in every drawing, and that happens automatically. So uncheck that option, so you have the ability to load code only when AutoCAD starts, which is what Acad.lsp has been used for since AutoCAD 2000.

    Now, about your real issue... how reliable is your network? Does the problem go away if your files are local?

    Intresting about the "Load acad.lsp with every drawing" option. I turned that off.

    with regards to the acad***.lsp files, I am a bit confused. in the support directory there is an Acad2000.lsp, Acad2000Doc.lsp file. Which one should I be loading?

    Currently I have Acad2000doc.lsp file, and my Custom.lsp file loading through the CUI. My custom.lsp file contains autoload information for allot of the lsp & arx add ons we use.

  4. #4
    Administrator Opie's Avatar
    Join Date
    2002-01
    Location
    jUSt Here (a lot)
    Posts
    9,135
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by tim.101799
    Intresting about the "Load acad.lsp with every drawing" option. I turned that off.

    with regards to the acad***.lsp files, I am a bit confused. in the support directory there is an Acad2000.lsp, Acad2000Doc.lsp file. Which one should I be loading?

    Currently I have Acad2000doc.lsp file, and my Custom.lsp file loading through the CUI. My custom.lsp file contains autoload information for allot of the lsp & arx add ons we use.
    You can create a new file named ACADDOC.LSP. You would need to place you customization that needs to be loaded for each drawing in that file. If it only needs to be loaded per session, then place it in the ACAD.LSP file. Both of these files can be user created.
    If you have a technical question, please find the appropriate forum and ask it there.
    You will get a quicker response from your fellow AUGI members than if you sent it to me via a PM or email.
    jUSt

  5. #5
    I could stop if I wanted to
    Join Date
    2005-12
    Location
    Hartford, CT
    Posts
    394
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by Opie
    You can create a new file named ACADDOC.LSP. You would need to place you customization that needs to be loaded for each drawing in that file. If it only needs to be loaded per session, then place it in the ACAD.LSP file. Both of these files can be user created.
    After I creat one of those files do I need to add that to my CUI? Also, can I just rename my custom.lsp to one of the file names you listed, and does it really need to be renamed?

  6. #6
    Administrator Opie's Avatar
    Join Date
    2002-01
    Location
    jUSt Here (a lot)
    Posts
    9,135
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    It does not need to be included within your CUI, but does need to be located within the Support Paths for the selected Profile. The two file names I mentioned will automatically be loaded by AutoCAD upon start up of the session and/or drawing. The first instance of each file found in the Support Paths will be the files to be loaded. If you have additional versions, AutoCAD will not load each version per session, only the first found.

    You could rename your custom.lsp file to the appropriate name or you could leave it as is and provide a (load "custom.lsp") callout in your ACAD.LSP or ACADDOC.LSP file.
    If you have a technical question, please find the appropriate forum and ask it there.
    You will get a quicker response from your fellow AUGI members than if you sent it to me via a PM or email.
    jUSt

  7. #7
    I could stop if I wanted to
    Join Date
    2005-12
    Location
    Hartford, CT
    Posts
    394
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by Opie
    It does not need to be included within your CUI, but does need to be located within the Support Paths for the selected Profile. The two file names I mentioned will automatically be loaded by AutoCAD upon start up of the session and/or drawing. The first instance of each file found in the Support Paths will be the files to be loaded. If you have additional versions, AutoCAD will not load each version per session, only the first found.

    You could rename your custom.lsp file to the appropriate name or you could leave it as is and provide a (load "custom.lsp") callout in your ACAD.LSP or ACADDOC.LSP file.
    I will give that a try. I will let you know how it works out.

    Currently I have Acad200Doc.lsp and my custom.lsp file loading through the cui. Should I remove them from the CUI?

  8. #8
    Administrator Opie's Avatar
    Join Date
    2002-01
    Location
    jUSt Here (a lot)
    Posts
    9,135
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by tim.101799
    I will give that a try. I will let you know how it works out.

    Currently I have Acad200Doc.lsp and my custom.lsp file loading through the cui. Should I remove them from the CUI?
    That is up to you. I don't load any lisps via the CUI. I use an ACAD.LSP and ACADDOC.LSP file instead.
    If you have a technical question, please find the appropriate forum and ask it there.
    You will get a quicker response from your fellow AUGI members than if you sent it to me via a PM or email.
    jUSt

  9. #9
    I could stop if I wanted to
    Join Date
    2005-12
    Location
    Hartford, CT
    Posts
    394
    Login to Give a bone
    0

    Default Re: Custom menus & lisp not always loading

    Quote Originally Posted by Opie
    That is up to you. I don't load any lisps via the CUI. I use an ACAD.LSP and ACADDOC.LSP file instead.
    OK....I think I will give both meathods a try and see which one works better.

Similar Threads

  1. Replies: 2
    Last Post: 2015-04-17, 04:00 PM
  2. Loading CUI and Menus through lisp
    By dmb87 in forum AutoLISP
    Replies: 1
    Last Post: 2014-06-03, 01:43 AM
  3. Loading Partial Menus
    By visualmatrix in forum AutoCAD Customization
    Replies: 7
    Last Post: 2011-07-15, 12:03 PM
  4. loading pull down menus
    By daniel.144778 in forum AutoCAD 3D (2007 and above)
    Replies: 1
    Last Post: 2010-10-11, 05:22 PM
  5. RPC Menus not loading
    By archdraught in forum ACA General
    Replies: 2
    Last Post: 2009-08-14, 04:42 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •