Results 1 to 8 of 8

Thread: Jagged shadows using mental ray render

  1. #1
    I could stop if I wanted to PaperStreet SoapCO's Avatar
    Join Date
    2006-06
    Location
    Fort Collins, CO
    Posts
    320
    Login to Give a bone
    0

    Default Jagged shadows using mental ray render

    Does anyone know what the deal is with the jagged shadows I am getting? I am using the mental ray render with final gather set to 100 I believe. And its incredibly green for some reason.
    Attached Images Attached Images
    Chad

    RA 2011 x64, Piranesi 2010 Pro, Sketchup 8, Windows 7 x64, Intel Core i7 720QM, 10GB RAM, ATI Mobility Radeon HD 5870 1GB RAM

  2. #2
    AUGI Addict .chad's Avatar
    Join Date
    2006-04
    Location
    is it lunch time yet?
    Posts
    1,129
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    there are a ton of different possiblities for that =/ (all train of thought solutions here, i havent used max in a while)

    what is your output resolution set to? a higher quality image frequently corrects anomalies like that.

    how is the model made? as an exterior render i dont think this is the cause, but i have had issues with shadows and lights where materials come together if they arent seamless (ie modeled in CAD - then exported)

    i havent used mental ray, so i cant say that this will work - but in your shadow options, what is it set to? you should have several options - ray trace, ambient etc (i dont have max around at the moment to verify the options - if i saw them i could tell you)

    for the green - turn down the reflectance of your ground material, and change the ambient color of your light source. if you arent using a daylighting / sun system i would switch to one and just use the standard lights for point lights and highlighting areas that might not be getting enough light (under the balcony and inside.) as bright as that scene is, the inside should be well lit with just the ambient light passing through the glass.

    how did you apply your materials? since the shadows are wrapping around corners and into the light source (a physical impossiblity) there is a chance your UVW mapping is skewed a little bit.

    and - just for a nice finishing touch - add a bump map to your stone finish, it will make the rendering considerably better looking, and get some depth to it. it looks like a map was applied to a flat face.
    This aggression will not stand. Man.

  3. #3
    I could stop if I wanted to PaperStreet SoapCO's Avatar
    Join Date
    2006-06
    Location
    Fort Collins, CO
    Posts
    320
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    First, thank you for your in depth response - I appreciate it.

    - My output resolution was set to 800 x 600.

    - The model was made in Revit, exported as a .dwg and imported into Max.

    - I have a sunlight / daylight system in and the shadows are set to mental ray shadow map. I thought the inside should be lit much better as well - I dont know if this has to do with the different exposure controls.

    - I figured the green had something to do with the reflectance of the material. All of the materials were dragged from the editor on to the materials themselves thus replacing all instances a particular material. I've never really had a problem with UVW mapping before using this method but I guess there's a first time for everything.

    - I had added a bump map to those stones but I think it wasnt enough - I guess this image is more of a test run then a final shot.

    Thank you for all of your help - I am pretty new to the workings of max.
    Chad

    RA 2011 x64, Piranesi 2010 Pro, Sketchup 8, Windows 7 x64, Intel Core i7 720QM, 10GB RAM, ATI Mobility Radeon HD 5870 1GB RAM

  4. #4
    AUGI Addict .chad's Avatar
    Join Date
    2006-04
    Location
    is it lunch time yet?
    Posts
    1,129
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    Quote Originally Posted by paperstreet_soapco

    - My output resolution was set to 800 x 600.
    try an output that is double that. lower output forces pixelation, which leads to weird things with materials and shadows. there was a thread on brick patterns you might search for.

    - The model was made in Revit, exported as a .dwg and imported into Max.
    probably not the model then

    - I have a sunlight / daylight system in and the shadows are set to mental ray shadow map. I thought the inside should be lit much better as well - I dont know if this has to do with the different exposure controls.
    like i said, ive never used mental ray, so i dont know anything about the shadow controls. i remember in the standard max shadow options (usually controlled by the light source from what i recall) they range from blocky area shadows to ray traced shadows - but like i said earlier, i dont have max around at the moment to really look those up.

    - I figured the green had something to do with the reflectance of the material. All of the materials were dragged from the editor on to the materials themselves thus replacing all instances a particular material. I've never really had a problem with UVW mapping before using this method but I guess there's a first time for everything.
    *shrug* might not have anything to do with it i was just running through things i remember causing issues.

    - I had added a bump map to those stones but I think it wasnt enough - I guess this image is more of a test run then a final shot.
    bump mapping can be tricky to get right. too much map and it looks bad, too little and it looks flat. when you make your bump, be sure that it has some lows and highs in the stones themselves, not just the joints. you can also apply a single noise map to the entire surface to impart some random irregularity to it. if you can find some tutorials (ive looked and havent found a good one) on dirt mapping look at that too - it will add some realism (grime) to your image

    Thank you for all of your help - I am pretty new to the workings of max.
    sure thing i wish i could use max at work i havent used it since i graduated, and i kind of miss it...
    This aggression will not stand. Man.

  5. #5
    AUGI Addict .chad's Avatar
    Join Date
    2006-04
    Location
    is it lunch time yet?
    Posts
    1,129
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    have a look here also.
    This aggression will not stand. Man.

  6. #6
    Design Visualization Moderator stusic's Avatar
    Join Date
    2004-10
    Location
    Denver, Colorado
    Posts
    1,514
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    For the jagged model:

    1. Make sure your anti-aliasing is turned on.


    For the jagged shadows:

    1. Set your mental ray shadow map resolution higher, like maybe 1024 or 2048 (this will make the render take longer).

    2. Set your sample rate higher.

    For the green color:

    Is your shadows using the green from the grass? I'm not sitting in front of 3ds right now, so i can't remember what it's called - there's a setting that will have the shadow absorb color from lights and the surroundings...

    Volumetric lights and rendering effects may also cast shadows and mix their colors with shadow colors.
    Phillip Bradshaw
    Lead Pixel Pusher, Lucid Design Studio
    CAD Detailer, Proctor Productions

    A doctor can bury his mistakes but an architect can only advise his clients to plant vines. - Frank Lloyd Wright

  7. #7
    Member
    Join Date
    2005-08
    Posts
    4
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    I would like to offer some suggestions if I could. I like to use presets and some people may not know how to get to them, but I use them all the time. Also knowing when to use certain lights will help too.
    I have attached a screen shot of where the presets are. Just keep in mind, you WILL have to tweek each one for a specific sceen, but at least it will get you to 90%. Hope this helps.

  8. #8
    All AUGI, all the time arshiel88's Avatar
    Join Date
    2005-02
    Location
    Off the Grid
    Posts
    560
    Login to Give a bone
    0

    Default Re: Jagged shadows using mental ray render

    This is an old thread but I just want to inform all that using Shadow Maps in Mental Ray is not recommended. Instead, Area Lights must be used to achieve soft shadows. I learned this info by reading this blog by Master Zap who knows Mental Ray more than we do. If you're 100% Mental Ray user, you probably know this guy.

    Shielbern Bolalin
    Architectural 3D Renderer
    ----------------------------------------------------------------------
    “A clever person solves a problem. A wise person avoids it.”

    1879-1955

Similar Threads

  1. 2015: Mental Ray Render: Lighting is Blown Out Sometimes
    By jen699232 in forum 3ds Max - mental ray
    Replies: 1
    Last Post: 2016-07-21, 03:03 PM
  2. 2012: Jagged Shadows in 3D View
    By marlasmith in forum Revit Architecture - General
    Replies: 0
    Last Post: 2011-10-04, 03:44 PM
  3. Replies: 1
    Last Post: 2008-09-18, 01:15 PM
  4. standalone mental ray vs. 3ds Max's internal mental ray
    By stusic in forum 3ds Max - mental ray
    Replies: 14
    Last Post: 2007-04-17, 04:18 PM
  5. Soft shadows from lights = jagged edges
    By patricks in forum Revit - Rendering
    Replies: 1
    Last Post: 2006-02-25, 06:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •