Results 1 to 6 of 6

Thread: Help starting a LISP command

  1. #1
    Member gurudas.ku's Avatar
    Join Date
    2006-10
    Location
    NewDelhi
    Posts
    39
    Login to Give a bone
    0

    Default Help starting a LISP command

    hi friends i am very new to Auto Lisp how can i invoke Auto lisp command, i type auto lisp in command prompt, but there is an error comes its an invalid command, i have a some of lisp tutorials,
    Hope a reply ASAP

  2. #2
    Time Lord Steve_Bennett's Avatar
    Join Date
    2015-12
    Location
    far, far, far away...
    Posts
    4,722
    Login to Give a bone
    0

    Default Re: Help starting a LISP command

    Please note I have moved this to the AutoLISP forum from the ADT tips/tricks forum as I feel this is a more appropriate place for it to receive a better response.
    Steve Bennett |BIM Manager
    Taylor Design | Adventures in BIM

  3. #3
    AUGI Addict .T.'s Avatar
    Join Date
    2000-12
    Location
    Lost
    Posts
    1,473
    Login to Give a bone
    0

    Default Re: Help starting a LISP command

    Quote Originally Posted by gurudas.ku
    hi friends
    I am very new to Auto lisp,i have a some of tutorials in lisp also , realy what i am facing is i am not able to invoke autolisp command. when i type Autolisp in command prompt invalid command error is comming how can i resolve this issue.
    Hope a reply ASAP
    If I understand you correctly (and this is just a guess), you are trying to get to the VL interface. Just type VLIDE at the command prompt. Let us know if I have made a bad guess.
    Last edited by Opie; 2006-12-14 at 02:08 PM. Reason: Removed unnecessary comment
    Tim Creary
    S&D
    DILLIGAF

  4. #4
    Administrator Opie's Avatar
    Join Date
    2002-01
    Location
    jUSt Here (a lot)
    Posts
    8,434
    Login to Give a bone
    0

    Default Re: Help starting a LISP command

    Quote Originally Posted by gurudas.ku
    hi friends i am very new to Auto Lisp how can i invoke Auto lisp command, i type auto lisp in command prompt, but there is an error comes its an invalid command, i have a some of lisp tutorials,
    Hope a reply ASAP
    Which version of AutoCAD are you using?
    If you have a technical question, please find the appropriate forum and ask it there.
    You will get a quicker response from your fellow AUGI members than if you sent it to me via a PM or email.
    jUSt

  5. #5
    I could stop if I wanted to
    Join Date
    2003-11
    Posts
    277
    Login to Give a bone
    0

    Default Re: Help starting a LISP command

    Hi gurudas.ku,
    For the best solution you should post here your code,without seeing your code,I can not help you.
    Here as a sample code
    Code:
    (defun c:test (/ p1 p2 p3 p4)
    (setq p1 '(0 0 0))
    (setq p2 '(10 0 0))
    (setq p3 '(10 5 0))
    (setq p4 '(0 5 0))
    (command "_pline" p1 p2 p3 p4 "c" "")
    (princ)
    )            ; defun
    Now you do,block that code with your cursor then hit right button,hit copy.
    open your cad,at command prompt type "vlide",find icon "new file",hit them and click at upper left corner,then hit right button your mouse,hit paste.
    save as your folder and give them name with extention lsp,find again icon "load active edit window",hit them.
    move session to acad,at command prompt type "test",now watching it,and what happended in drawing area.


    Quote Originally Posted by gurudas.ku
    hi friends i am very new to Auto Lisp how can i invoke Auto lisp command, i type auto lisp in command prompt, but there is an error comes its an invalid command, i have a some of lisp tutorials,
    Hope a reply ASAP
    Last edited by Opie; 2006-12-15 at 05:59 PM. Reason: fixed code tag

  6. #6
    Member gurudas.ku's Avatar
    Join Date
    2006-10
    Location
    NewDelhi
    Posts
    39
    Login to Give a bone
    0

    Default Re: Help starting a LISP command

    i am using autocad 2006 and 2007

Similar Threads

  1. starting a custom command from two variables
    By MikeViller in forum AutoLISP
    Replies: 4
    Last Post: 2014-12-23, 01:11 PM
  2. Replies: 3
    Last Post: 2009-10-22, 10:19 PM
  3. LISP not starting
    By cadman_meg in forum AutoLISP
    Replies: 4
    Last Post: 2007-12-19, 12:42 PM
  4. Replies: 17
    Last Post: 2006-11-03, 12:56 AM
  5. Starting with LISP
    By panchalashi in forum ATP Course Wishlist
    Replies: 1
    Last Post: 2006-04-26, 06:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •