*I'm placing this in the Civil3D forum because it pertains to C3D objects. If it needs to be moved please feel free to do so.

I'm working on a 400-lot subdivision. I have a base drawing that get xref'ed into the plan sheets. I opened my base in LDT 2007 this morning, and have kept it open throughout the day. Inside this base are my C3D objects such as surface, alignments, prodiles, pipe networks, etc. There usually is no problem there.

However we're in the process up upgrading to 2008. One of the draftspeople told me that they were having problems displaying the C3D projects in their drawing when opening it in C3D '08. So I checked it and sure enough, most of the C3D objects weren't displaying. Eventually I went back to my own computer, started C3D '08, and xrefed in my base, which was still open in LDT '07. It worked just fine, everything displayed right. So I figured something was just wrong with his drawing. Other drawing were displaying everything right and they were all using the same xref.

20 minutes later, he complained that again, things weren't displaying, and it was happening with all of his drawings. So, I check my base that is still open in LDT'07, and everything looks good there. I opened C3D '08 and tried to open my base in read-only, and my profile grids were there, but no profiles or alignments. My sewer manholes in the plan view were all yellow squares (proxies?).

I then opened LDT '07 and tried to open the same base in read-only and I had the exact same problem! The base is open in LDT '07 and displaying perfectly, but when I open another session of the SAME PROGRAM and open the drawing in read-only, it won't display right.

What the heck is the problem? This is a huge project and I'm getting pretty worried because I can't open the base or xref it into any version of ACAD that I have, and neither can the draftspeople.

I REALLY appreciate any advice on this.