Results 1 to 6 of 6

Thread: Custom toolbar icons mirroring other toolbar icons or missing completely

  1. #1
    I could stop if I wanted to artisteroi's Avatar
    Join Date
    2007-02
    Location
    Tampa, FL
    Posts
    271
    Login to Give a bone
    0

    Question Custom toolbar icons mirroring other toolbar icons or missing completely

    got a custom toolbar for my vba program, and trie to copy it to another inhouse machine and the tool bar picked up the icon images of the toolbar above it in the cui file editor. where ever i moved it to it always looked like the one above it. And if the one above it had fewer icons then the rest of my toolbar icons were blank, just showed an empty toolbar.
    In the editor it had the right images but didn't seem to display it in the live bar on the desktop.
    anyone got any idea what would cause that? I am going to make a dll using the afralisp program but if this is beacuse of an installation error I would like to fix it. anyone know?

  2. #2
    The Silent Type Mike.Perry's Avatar
    Join Date
    2000-11
    Posts
    13,654
    Login to Give a bone
    0

    Default Re: Custom toolbar icons mirroring other toolbar icons or missing completely

    Hi "artisteroi"

    Please note I have *moved* this thread from the VBA forum to this one, as I feel this particular forum is a more appropriate place for such a topic.

    Thanks, Mike

    Forum Manager

  3. #3
    The Silent Type Mike.Perry's Avatar
    Join Date
    2000-11
    Posts
    13,654
    Login to Give a bone
    0

    Default Re: Custom toolbar icons mirroring other toolbar icons or missing completely

    Hi

    For starters, see if the following offers any help...

    Toolbar images not being successfully applied to custom toolbar

    RE: Icon disappear from toolbar

    ID: TS1055063 - Adding new toolbar buttons

    Have a good one, Mike

  4. #4
    The Silent Type RobertB's Avatar
    Join Date
    2000-01
    Location
    Seattle WA USA
    Posts
    5,859
    Login to Give a bone
    0

    Default Re: Custom toolbar icons mirroring other toolbar icons or missing completely

    There is a .NET API for the CUI. Have you tried that? If not, are you creating a separate CUI to load as partial, to provide the toolbar? That will be the only way to get the separate resource .dll to work.

  5. #5
    Member
    Join Date
    2001-11
    Posts
    11
    Login to Give a bone
    0

    Default Re: Custom toolbar icons mirroring other toolbar icons or missing completely

    "There is a .NET API for the CUI. Have you tried that? If not, are you creating a separate CUI to load as partial, to provide the toolbar? That will be the only way to get the separate resource .dll to work."

    What is a ".NET API for the CUI"?

    I have just joined this thread, however, I am having a similar problem, I think. Since the poster did not answer your question I will. Yes, I am creating a separate CUI (".mnu") to load as a partial menu to provide the toolbar. If you will, please look at the following which explains my condition much more thoroughly:
    rick.21832

    Thanks
    RB

  6. #6
    The Silent Type RobertB's Avatar
    Join Date
    2000-01
    Location
    Seattle WA USA
    Posts
    5,859
    Login to Give a bone
    0

    Default Re: Custom toolbar icons mirroring other toolbar icons or missing completely

    Quote Originally Posted by rick.21832 View Post
    ... I am having a similar problem, I think. Since the poster did not answer your question I will. Yes, I am creating a separate CUI (".mnu") to load as a partial menu to provide the toolbar.
    You don't want to do that. Load all interface elements (i.e. load all CUI files) and use workspaces to control the visible elements. DO NOT SWAP "MENUS".
    R. Robert Bell
    Design Technology Manager
    Stantec
    Opinions expressed are mine alone and do not reflect the views of Stantec.

Similar Threads

  1. Toolbar Icons Don't Match Toolbar Function
    By walkonfire984109 in forum AutoCAD LT - General
    Replies: 1
    Last Post: 2010-11-17, 08:04 PM
  2. Toolbar icons missing
    By niall_fitzgerald in forum ACA General
    Replies: 0
    Last Post: 2009-09-30, 07:35 PM
  3. Custom Toolbar icons show as ? marks
    By tony.nichols in forum AutoCAD CUI Menus
    Replies: 2
    Last Post: 2006-01-23, 04:03 AM
  4. Custom CUI and custom toolbar icons
    By kschultz in forum AutoCAD CUI Menus
    Replies: 8
    Last Post: 2005-10-14, 03:25 PM
  5. Missing toolbar icons
    By sifuentes in forum AutoCAD General
    Replies: 2
    Last Post: 2005-09-09, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •