See the top rated post in this thread. Click here

Results 1 to 3 of 3

Thread: Problema alterando os atributos com LISP

  1. #1
    Member abdala's Avatar
    Join Date
    2006-10
    Posts
    10
    Login to Give a bone
    0

    Smile Problema alterando os atributos com LISP

    Fiz uma rotina que altera a legenda do desenho, que contém um bloco com atributos.
    Porém quando tem uma vírgula no texto dá um erro no programa, veja abaixo:

    (command "-attedit" "N" "N" "ATRIBUTO" "PESO" pesovelho pesovelho pesotxt)

    Onde:
    ATRIBUTO = Block name
    PESO = Tag name
    pesovelho = valor atual ou antigo
    pesotxt = novo valor.

    Como o peso do componente aqui na empresa é separado por vírgula, sempre dá erro.
    Assim ocorre após a linha em LISP acima:
    *Invalid*
    ; error: Function cancelled


    Se alguém tiver uma idéia agradeço.

  2. #2
    Login to Give a bone
    1

    Default Re: Problema alterando os atributos com LISP

    Olá Abdala,

    Parece que nem os mestres do Discussion Groups conseguem explicar porque isto acontece .
    Talvez haja esta protecção (ou bug) para evitar conflitos com a exportação em CSV, mas é só uma teoria.

    Partindo do princípio que em cada Attribute Value existe apenas uma vírgula, eu tentaria usar o wild-card character '?' em vez de ','.
    Exemplificando, se o pesovelho fosse 1234,56, a resposta ao attribute value specification seria 1234?56.

    Outra solução poderia passar por uma rotina mais elaborada alterando os valores dos atributos com instruções do tipo entget e entmod.

    Espero ter ajudado.
    Last edited by jorge.anjos; 2007-06-07 at 01:47 PM.
    Jorge Anjos
    Tomar - Portugal

  3. #3
    100 Club
    Join Date
    2007-05
    Location
    São Paulo - SP - Brazil
    Posts
    181
    Login to Give a bone
    0

    Default Re: Problema alterando os atributos com LISP

    voce já tentou usar o codido ACII da virgula no lugar da propria?
    ou ainda melhor tenta alterar o atributo sem passar pela linha de comando com os comando entmode

    Quote Originally Posted by abdala
    Fiz uma rotina que altera a legenda do desenho, que contém um bloco com atributos.
    Porém quando tem uma vírgula no texto dá um erro no programa, veja abaixo:

    (command "-attedit" "N" "N" "ATRIBUTO" "PESO" pesovelho pesovelho pesotxt)

    Onde:
    ATRIBUTO = Block name
    PESO = Tag name
    pesovelho = valor atual ou antigo
    pesotxt = novo valor.

    Como o peso do componente aqui na empresa é separado por vírgula, sempre dá erro.
    Assim ocorre após a linha em LISP acima:
    *Invalid*
    ; error: Function cancelled


    Se alguém tiver uma idéia agradeço.

Similar Threads

  1. 2014: Lisp para insertar bloque con atributos
    By Raúl Niembro in forum Español - AutoCAD / AutoCAD LT
    Replies: 0
    Last Post: 2015-03-19, 11:50 PM
  2. Problema extraer atributos de bloque dinámico
    By valdepiedra in forum Español - AutoCAD / AutoCAD LT
    Replies: 1
    Last Post: 2010-01-12, 09:24 PM
  3. BLOQUE CON ATRIBUTOS
    By aprias in forum Español - AutoCAD / AutoCAD LT
    Replies: 3
    Last Post: 2009-02-02, 09:29 PM
  4. edição de atributos
    By rapfonseca in forum Português - AutoCAD / AutoCAD LT
    Replies: 2
    Last Post: 2009-01-29, 01:58 PM
  5. LISP: problema come move despues de insert
    By dgomez.189897 in forum Español - AutoCAD / AutoCAD LT
    Replies: 3
    Last Post: 2008-08-28, 04:52 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •