Results 1 to 6 of 6

Thread: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

  1. #1
    Member
    Join Date
    2005-10
    Posts
    36
    Login to Give a bone
    0

    Default Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern- Revit 2008 Bug?

    I was wondering if anyone else has noticed the follow issue with Revit 2008:

    When importing AutoCAD details into Revit 2008 with the scale set to: Auto-Detect some of the AutoCAD hatch patterns come in as solid black instead of showing the proper hatch pattern. Now, here is the interesting part, this only appears to happen in Revit 2008. If I bring the exact same detail into Revit 9.0 or Revit 9.1, the hatch patterns appear correctly. I was thinking that this was how the patterns are being created in AutoCAD but this doesn't happen in previous versions of Revit so it would appear that something has changed in Revit 2008. Also, I am working with other clients that are having the same issue

    Currently, the solution (i.e. work around) is to import details using Custom scaling set to 1.00000. Then select the imported detail and resize the detail by .0833333333 (1/12) so that it is at the proper scale. Doing this, the hatch patterns come in correctly and remain correctly displayed when scaled down by a factor of 12.

    Does anyone know if there is a solution or settings that needs to be modified to resolve this? While the workaround solves the issue, it is truely a pain to have to scale every detail that is imported.

    Thanks,

    Ken Marcus
    Revit Intergration Consultant
    RFI Consultants Inc.
    Oakland, CA
    415.979.0678
    kenmarcus@rficonsultants.com
    Last edited by kenmarcus; 2008-01-16 at 12:14 AM. Reason: title change to hopefully get more input

  2. #2
    AUGI Addict DaveP's Avatar
    Join Date
    2002-12
    Location
    St Paul, MN
    Posts
    1,568
    Login to Give a bone
    0

    Default Re: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

    Sounds like you're having problems with Model patterns vs Detail patterns.
    Model patterns remain the same size regardless of the scale of the View - think Brick patterns on a wall.
    Detail patterns scale up & down with the scale of the View and are always PRINTED at the same "size" - think the Earth pattern for elevations.

    My guess is that you've got a Model pattern on your details & you need to change it to a Detail pattern. (I'd explain how here, but I'm in the midst of waiting for my 300 Meg project to finish up.)
    Go back to AutoCAD? I'd rather lose my right arm!

  3. #3
    Member
    Join Date
    2005-10
    Posts
    36
    Login to Give a bone
    0

    Default Re: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

    David,

    I am familiar with the difference between model and drafting patterns and I was not thinking that was the issue but you bring up an interesting point. As I mentioned, this is happening with AutoCAD details that have been imported into drafting views in Revit 2008. Nothing is drawn in the drafting view. So here is the next question, when AutoCAD files are imported into Revit files, does it map the AutoCAD hatch pattern to a similar Revit pattern and scale based upon how that pattern is defined in Revit (Drafting vs Model) and if so, would I need to create the same pattern as a model pattern prior to importing the detail into Revit so that the pattern scales properly? How does Revit choose which pattern type (drafting or model) is used if both exist in your project?

  4. #4
    Member mmulvey's Avatar
    Join Date
    2004-02
    Location
    San Diego
    Posts
    43
    Login to Give a bone
    0

    Default Re: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

    Quote Originally Posted by kenmarcus View Post
    I was wondering if anyone else has noticed the follow issue with Revit 2008:

    When importing AutoCAD details into Revit 2008 with the scale set to: Auto-Detect some of the AutoCAD hatch patterns come in as solid black instead of showing the proper hatch pattern. Now, here is the interesting part, this only appears to happen in Revit 2008. If I bring the exact same detail into Revit 9.0 or Revit 9.1, the hatch patterns appear correctly. I was thinking that this was how the patterns are being created in AutoCAD but this doesn't happen in previous versions of Revit so it would appear that something has changed in Revit 2008. Also, I am working with other clients that are having the same issue

    Currently, the solution (i.e. work around) is to import details using Custom scaling set to 1.00000. Then select the imported detail and resize the detail by .0833333333 (1/12) so that it is at the proper scale. Doing this, the hatch patterns come in correctly and remain correctly displayed when scaled down by a factor of 12.

    Does anyone know if there is a solution or settings that needs to be modified to resolve this? While the workaround solves the issue, it is truely a pain to have to scale every detail that is imported.

    Thanks,

    Ken Marcus
    Revit Intergration Consultant
    RFI Consultants Inc.
    Oakland, CA
    415.979.0678
    kenmarcus@rficonsultants.com
    We had the same problem. Needed to import over 90 ACAD details. All hatches were coming in solid - here's our solution:

    Go to file/import/cad etc.
    Set color to "Black & White"
    Leave scale at "Auto-Detect" (otherwises detail scales a real pain to get right)
    browse to and Import file

    What's interesting is that whatever you change here sets the parameters for any DWG files that are subsequently dragged/dropped into Revit from Windows Explorer.

    This seemed to cure <<almost>> all hatch problems except for those where the hatch scale was set in ACAD to any value less than 4 - this probably relates to the fact that ACAD hatch pattern scales were set way back at 1/8 DU (= 1/8 inch for most users) - a really dumb idea if you ask me - I re-wrote the ACAD.PAT file bach in the 1980-'s and have been nagging them to change it since about release 1.4 - nothing doing...

    Anyway, if you change the hatch scale to 4 or above (messes up the pattern and I haven't had time to test using a more closely-defined pattern at the same (>4) hatch scale) everything seems to work as long as the view scale matches the original ACAD detail scale.
    Mike

  5. #5
    Member
    Join Date
    2008-02
    Posts
    2
    Login to Give a bone
    0

    Smile Re: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

    I had same issue. Following posts here, I get a way works for my CAD file:

    ( AutoCAD2008 file: 1 1/2" detail, 1:1, unit=inch )

    link file into Revit 2008:
    /Import unit: auto detect
    /Layer/Level Colors: BW or Preserve colors, won't work for Invert Colors

    After import, the detail will be scaled to 1:1, inch unit, with correct hatch.
    Then I "resize" the drawing to 1/8, the hatch scales accordingly.

    But the linetype is not correct though...
    Last edited by xhuang; 2008-03-14 at 08:58 PM.

  6. #6
    I could stop if I wanted to mruehr's Avatar
    Join Date
    2004-01
    Location
    Perth
    Posts
    223
    Login to Give a bone
    0

    Default Re: Imported AutoCAD hatch patterns shown as solid black instead of proper hatch pattern

    i think for the line type you have to set the line type scale in acad to 1

Similar Threads

  1. Replies: 4
    Last Post: 2013-01-06, 07:00 PM
  2. hatch patterns on Imported AutoCAD Drawings
    By burchd in forum Revit Architecture - General
    Replies: 2
    Last Post: 2008-11-03, 07:09 PM
  3. Replies: 10
    Last Post: 2008-02-27, 05:28 PM
  4. Imported hatch patterns
    By jjjschoeman in forum Revit Architecture - General
    Replies: 2
    Last Post: 2006-09-07, 01:54 AM
  5. White solid hatch turning black
    By jv3dcad in forum Revit Architecture - General
    Replies: 4
    Last Post: 2006-01-29, 03:13 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •