Results 1 to 10 of 10

Thread: Unable to detach xref

  1. #1
    I could stop if I wanted to michael.12445's Avatar
    Join Date
    2001-03
    Posts
    350
    Login to Give a bone
    0

    Default Unable to detach xref

    I have a site plan drawing with a building where an external stair is being changed to an internal stair. The external stair was drawn as an xref and attached to the site plan drawing. This xref cannot be detached: "Unable to detach. Multiple references detected."

    I searched here and on Autodesk's site, and found two known causes of this error: (1) the xref occurs in more than one layout, and has to be erased from all but one layout before it can be detached, or; (2) the xref is nested inside another xref attached to the parent drawing. My site plan drawing has only one layout, with no insertions of the problem xref; in fact, there are no insertions of it in model space, either (they were all erased), so condition (1) isn't true.

    As for condition (2), the Xref Manager does not show the xref attached to any other drawing in the tree view - the tree view only shows it attached directly to the site plan drawing. Just to make sure, I used Etransmit to copy the site plan drawing and all its xrefs to my C: drive, stripping out all the paths, and then opened each dwg file to see if it referenced the problem xref. None of them, except the site plan itself, show the xref in the Xref Manager.

    Anybody have any ideas what could be going on here?

    Thanks,

    Michael Evans
    Togawa Smith Martin Residential, Inc.

  2. #2
    Certifiable AUGI Addict ccowgill's Avatar
    Join Date
    2004-08
    Location
    Iron Station, NC
    Posts
    3,197
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    if you can, try detaching your main xref, then detach the troublesome xref if it still exists, then reattach the main xref

  3. #3
    I could stop if I wanted to michael.12445's Avatar
    Join Date
    2001-03
    Posts
    350
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    Quote Originally Posted by ccowgill View Post
    if you can, try detaching your main xref, then detach the troublesome xref if it still exists, then reattach the main xref
    There isn't really a "main" xref - the site plan drawing is composed of a bunch of xrefs (buildings and other pieces) inserted onto a property line. The problem xref is an independent piece, not one that is referenced by any of the building xrefs. There is a plot sheet that references the site plan drawing, so that the site plan drawing would be the "main" xref in that sheet, but I'm trying to detach the problem xref from the site plan drawing itself, not from the plot sheet that references the site plan drawing (if that makes sense!).

    Michael Evans
    Togawa Smith Martin Residential, Inc.

  4. #4
    I could stop if I wanted to
    Join Date
    2007-07
    Posts
    382
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    One possibility - check in the viewport of the layout to see if anything's been frozen in current layer.

  5. #5
    Certifiable AUGI Addict
    Join Date
    2015-11
    Location
    Jo'burg SA
    Posts
    4,512
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    The offending XRef could also be part of a block. This usually happens when binding Xrefs with nested xrefs inside.

  6. #6
    Certifiable AUGI Addict ccowgill's Avatar
    Join Date
    2004-08
    Location
    Iron Station, NC
    Posts
    3,197
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    well, you could try detaching all xrefs, then reattaching them one at a time, if the problem xref shows up, you will know which drawing is creating the problem

  7. #7
    All AUGI, all the time
    Join Date
    2000-12
    Location
    Blue Springs, MO
    Posts
    658
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    If I had to guess the stair is being referenced into more than one of the files making up your site plan. open the site plan then open each xref from there. You should find the little bugger in there somewhere. I was having similiar issues with some files recently where one the client's 5 background files was referencing one of the same files I was and I couldn't find out which one just by looking at the xref manager. I started at the top and worked my way down opening each files and there it was.

  8. #8
    Active Member
    Join Date
    2003-11
    Posts
    52
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    Also, in regards to the possibility of the stair being a block in one of the building xrefs, the block may not be inserted but the file has a block of that name that has been erased. You have to purge all the files that are referenced into sheet file. This is always a headache in our office when the architects attach a xref or insert a block in their building and then the Landscape side wants to attach the building to the site plan.

  9. #9
    I could stop if I wanted to michael.12445's Avatar
    Join Date
    2001-03
    Posts
    350
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    Thanks for all the suggestions.

    I finally fixed it. It turns out the xref was part of a block definition, and although there was an insertion of the block in the drawing, the xref didn't appear (the parent block may have been xclipped). Once I erased the block insertion and purged its definition, I was able to detach the problem xref.

    Now the odd thing is the name of the block was "A$C1A570076", which looks like the product of a COPYCLIP operation, yet it was made up of xrefs. Every time I've ever tried to include xrefs in a COPYCLIP selection set, the result in the target drawing is a block consisting of a line of text that spells out the path of the xref, not the xref itself...

    Anyway, the drawing is now fixed...Does anyone else think AutoCAD's referencing mechanism needs improvement?

    Thanks again,

    Michael Evans
    Togawa Smith Martin Residential, Inc.

  10. #10
    All AUGI, all the time
    Join Date
    2000-12
    Location
    Blue Springs, MO
    Posts
    658
    Login to Give a bone
    0

    Default Re: Unable to detach xref

    Quote Originally Posted by michael.12445 View Post
    Does anyone else think AutoCAD's referencing mechanism needs improvement?

    Thanks again,

    Michael Evans
    Togawa Smith Martin Residential, Inc.
    Yes, just ask anyone who has used Microstation and AutoCAD. I've never used it but I've heard MS is way better at handling xrefs.

Similar Threads

  1. Multiple Drawing Xref Detach
    By martyk in forum AutoLISP
    Replies: 3
    Last Post: 2012-08-05, 07:32 AM
  2. Xref overlay without detach
    By cadprog in forum Dot Net API
    Replies: 0
    Last Post: 2008-11-04, 08:46 AM
  3. Detach Xref by Selecting
    By wommack in forum AutoLISP
    Replies: 3
    Last Post: 2006-05-17, 10:55 PM
  4. Unable to detach a Xref
    By sherflor in forum AutoCAD General
    Replies: 6
    Last Post: 2006-03-09, 01:34 PM
  5. Cannot detach a xref
    By kleenhippie in forum AutoCAD General
    Replies: 2
    Last Post: 2005-08-24, 04:03 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •