Results 1 to 4 of 4

Thread: Problem with flexing rotating parameters in a crane

  1. #1
    Woo! Hoo! my 1st post
    Join Date
    2008-11
    Posts
    1
    Login to Give a bone
    0

    Default Problem with flexing rotating parameters in a crane

    I'm building a crawler crane which is a nested family, and also has 2 rotating parameters included. This is my Forster nested family design for my company & it's not cooperating with me. The crane itself is pretty much completed with the tracks being one family, 3 bodies are another, and the boom another. The body consist of 3 seperate body types which can be swapped using the yes/no parameter.the boom has a parameter which flex the boom up & down, with a pivot point on the front of the bodies. the problem I'm having is when I add a parameter to rotate the bodies, the body will turn, but the boom will appear to detach itself from the crane and point downwards( mirrored from it's original vertically 45 degree position( almost as if it's exploding when I try to flex it). The rest of the crane remains. Can someone please help me figure this out, thanks!

  2. #2
    100 Club
    Join Date
    2010-10
    Posts
    105
    Login to Give a bone
    0

    Default Re: Problem with flexing rotating parameters in a crane

    I think you need to post the file, It's really hard to know what you are working with.

  3. #3
    AUGI Addict jsteinhauer's Avatar
    Join Date
    2015-11
    Location
    Madison, WI
    Posts
    1,317
    Login to Give a bone
    0

    Smile Re: Problem with flexing rotating parameters in a crane

    Quote Originally Posted by eturtle2001 View Post
    I'm building a crawler crane which is a nested family, and also has 2 rotating parameters included. This is my Forster nested family design for my company & it's not cooperating with me. The crane itself is pretty much completed with the tracks being one family, 3 bodies are another, and the boom another. The body consist of 3 seperate body types which can be swapped using the yes/no parameter.the boom has a parameter which flex the boom up & down, with a pivot point on the front of the bodies. the problem I'm having is when I add a parameter to rotate the bodies, the body will turn, but the boom will appear to detach itself from the crane and point downwards( mirrored from it's original vertically 45 degree position( almost as if it's exploding when I try to flex it). The rest of the crane remains. Can someone please help me figure this out, thanks!
    I would use a Family Type parameter to switch out the different body styles instead of the yes/no parameters. If your boom is a face based family, try adding a reference plane at the height of the connection points. Then host your boom to that reference plane. Draw your reference line and assign the boom to that as it's workplane. If you are able to post this family, I'm sure several people will take a look at it for you. I have a link below to a thread I started when I was trying to do something similar.

    Cheers,
    Jeff S.


    http://forums.augi.com/showthread.php?t=77355
    'When I am working on a problem, I never think about beauty but when I have finished, if the solution is not beautiful, I know it is wrong.' - R. Buckminster Fuller

  4. #4
    All AUGI, all the time
    Join Date
    2008-11
    Location
    Australia
    Posts
    754
    Login to Give a bone
    0

    Default Re: Problem with flexing rotating parameters in a crane

    Theres a very good blog here with a worked example for nested crane...

    http://blog.cadway.com.au/2010/10/ma...ic-mobile.html

Similar Threads

  1. 2015: Problems Rotating Text with Parameters/Actions
    By Dingle Remains in forum Dynamic Blocks - Technical
    Replies: 0
    Last Post: 2014-05-20, 04:51 PM
  2. Constraints and Flexing problem
    By dbaldacchino in forum Revit Architecture - Families
    Replies: 35
    Last Post: 2009-08-03, 03:24 PM
  3. Problem rotating
    By munsey831 in forum AutoCAD General
    Replies: 11
    Last Post: 2009-04-07, 12:21 PM
  4. Rotating Text - Problem
    By Gigliano70 in forum Dynamic Blocks - Technical
    Replies: 5
    Last Post: 2008-05-27, 07:43 PM
  5. instance parameters flexing on reload...
    By sfaust in forum Revit Architecture - General
    Replies: 5
    Last Post: 2007-09-21, 05:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •