Results 1 to 2 of 2

Thread: Group Policy Installation of AutoCAD 2008 AND Civil 3D 2008

  1. #1
    Join Date
    Login to Give a bone

    Exclamation Group Policy Installation of AutoCAD 2008 AND Civil 3D 2008

    This all started with the new 2008 deployment creation tool. On AutoCAD we use Group Policy to deploy the basic AutoCAD package. Theses machines are all reformatted (full format), then have the basic drives, video, network, audio &chipset etc. installed. Then we install MS Installer 3.1, MS XML Parser 6.0 and Dot Net 3.5. This machine is then placed in the queue of GP for deployment. No other software is installed before the Autodesk product line.

    After a restart of the machine it begins to install AutoCAD 2008, Great!! But when we login to the machine and launch AutoCAD it appears to be missing a DLL. The strange thing is this happens randomly to a variety of machines, but not all of them, some machines come out fine. About half of our machines have encountered this issue.

    We have also found that a specific file dealing with the license does not get installed. This file causes problems with our license server which is holding onto license even thought someone has exited out of all AutoCAD products. This file tells the license server to release a license when a user exits AutoCAD.

    More Background on machines & deployments:

    1. We have a variety of Dells: Precisions, Dimensions and Optiplex-es.
    2. We are running Windows XP SP2 Professional all 32-bit.
    3. There is no pattern that we have been able to derive. We just purchased 2 brand new Precision 490’s, preformed all the same steps above and one was fine the other had the missing DLL.
    4. Gigabit Network cards.

    1. Dell Power Edge SC1420 running Windows Server 2003 R2 SP1.
    2. We have tried turning off the Virus program, made different deployment images and even tried a machine just for the deployment images. All had the same results.
    3. Network is a Gigabit network.

    Software-deployment image:
    1. These are created from the DVD’s straight from Autodesk.
    2. We tested the DVD’s by installing from them to make sure everything is working correctly.
    3. NO additional modifications are made to the image, except the direction to a license server.

    Missing DLL files:
    1. d3dx9_30.dll this is missing from the c:\WINDOWS\system32 directory.
    2. Error reads: “This application has failed to start because d3dx9_30.dll was not found. Re-installing the application may fix this issue.”

    NO, reinstalling does not fix this issue.

    We have written a script to place the missing DLL file into its proper directory to ban aid the issue.

    1. Why is it just this DLL?
    2. How can we get this to deploy correctly?

    THIS might be related to another issue with Civil 3D

    We follow all the steps above to create a Civil 3D deployment image. But when we start Civil 3D it pops up with the following error:

    “AutoCAD VBA is not currently installed. Please run the AutoCAD R2008 installer to install the AutoCAD VBA component.”

    We then try to uninstall Civil 3D, it goes through the process and says it has completed. When you go into the Windows “Install and Remove Programs list” it says it is still there but the icon looks like the basic AutoCAD icon. With GP this is normal, we then clear out the GP registry, and restart the computer. In some cases it reinstalls fine but others it will not re-install.

    We then grab the DVD and try to install from it and the following error occurs:

    “Error applying transforms. Verify that the specific transform paths are valid.”

    We have tired everything under the sun to get Civil 3D out of the machine but it requires a FULL REFORMAT. We have rebuilt the deployment image which has no change.

    These machines are then treated with 100% hands on install from the DVD’s and that appears to solve the problem.

    1. Why is the VBA component not installing?
    2. How can we fix this?

    Thanks for any help!

  2. #2
    Administrator Ed Jobe's Avatar
    Join Date
    Turlock, CA
    Login to Give a bone

    Default Re: Group Policy Installation of AutoCAD 2008 AND Civil 3D 2008

    The Network Administrator's Guide (acad_nag.chm) has information on using GP to deploy acad. If that doesn't help. I suggest you submit a tech call to adesk via subscription center to get more specific help.
    C:> ED WORKING....

Similar Threads

  1. AutoCAD 2008: This installation is forbidden by system policy
    By BunyipCatcher in forum AutoCAD General
    Replies: 17
    Last Post: 2010-04-23, 08:53 PM
  2. Replies: 2
    Last Post: 2008-04-30, 04:33 PM
  3. Replies: 0
    Last Post: 2008-02-11, 08:11 PM
  4. FYI - Civil 3D 2008 installation issue.
    By Brian Myers in forum AutoCAD Civil 3D - General
    Replies: 1
    Last Post: 2007-04-27, 11:39 PM
  5. Webcast for Civil Engineers: Introduction to AutoCAD Civil 3D 2008
    By Brogueira-CADptbr in forum Português - AutoCAD Civil 3D / AutoCAD Land Desktop / AutoCAD Map 3D
    Replies: 0
    Last Post: 2007-02-26, 10:34 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts