See the top rated post in this thread. Click here

Results 1 to 3 of 3

Thread: Deck Family Problems

  1. #1
    Member
    Join Date
    2008-02
    Posts
    10
    Login to Give a bone
    0

    Default Deck Family Problems

    I am trying to make a simple deck family. When I load the family into a project I get a "can't make type error" for all types except for the active type. The family seems to work fine in the family edit mode. Does anybody have any idea why this is happening. The family is attached.
    Attached Files Attached Files

  2. #2
    AUGI Addict Andre Carvalho's Avatar
    Join Date
    2006-06
    Location
    Toronto, ON
    Posts
    2,386
    Login to Give a bone
    1

    Default Re: Deck Family Problems

    Do it as a generic model and select "work planed based" under Settings > Family Category and parameters. It is better to do like that and then if you want you can load (nest) into a face based family, wall based family, ceiling based family, etc. If you create it as a face based family from the start, then you can't change it (unless if you copy and paste into a new generic model family and recreate all the parameters again...).

    See attached. I did it as a generic family (no face based, just generic family) and selected work planed based. You can host it on planes (floors, walls, roofs, etc.). I've recreated the parameters and a few types to test and it worked. If using my family, review the types.

    Andre Carvalho
    Attached Files Attached Files

  3. #3
    Member
    Join Date
    2008-02
    Posts
    10
    Login to Give a bone
    0

    Default Re: Deck Family Problems

    Thanks a lot. I think I would have been stuck forever if not for you help.

Similar Threads

  1. 2015: Nested/Host Parameters - Specifically Roof Deck Family
    By gross695874 in forum Revit Architecture - Families
    Replies: 1
    Last Post: 2015-07-17, 09:49 PM
  2. family problems
    By charliep in forum Revit Architecture - Families
    Replies: 3
    Last Post: 2008-08-05, 02:07 PM
  3. Really having Problems with this family!
    By dpatera1 in forum Revit Architecture - Families
    Replies: 4
    Last Post: 2006-05-18, 05:49 AM
  4. Family problems
    By kb7tjr in forum Revit Architecture - General
    Replies: 4
    Last Post: 1970-01-01, 02:03 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •