Results 1 to 8 of 8

Thread: When question marks appear in tags

  1. #1
    AUGI Addict ws's Avatar
    Join Date
    2004-09
    Location
    Ambleside, Lake District, UK
    Posts
    1,222
    Login to Give a bone
    0

    Default When question marks appear in tags

    Just getting into Schedules (after 2 years of using Revit ) and it is very impressive.

    However I was wondering if anyone could explain why say, window families created as generic models, inserted into walls successfully and then later changed category to 'Windows' via the Family Editor->Settings->Family Category & Parameters show up as question marks when tagged in plans/elevations rather than receiving a number.

    It is probably something simple but at the moment I can't see it.

  2. #2
    I could stop if I wanted to mthurnauer's Avatar
    Join Date
    2001-11
    Location
    Cincinnati, formerly Chicago
    Posts
    400
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    Have you assigned a Type Mark for the window?

  3. #3
    AUGI Addict ws's Avatar
    Join Date
    2004-09
    Location
    Ambleside, Lake District, UK
    Posts
    1,222
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    Many thanks, but you've lost me there just for the minute - although I'm a bit wiser for your pointer having looked that up in my various Revit books.

    Most of the windows I've created have a parameter called 'Mark' in the Properties and it contains a number - these all tag and schedule fine.

    The windows showing the question marks in the tag instead of a number also have the 'Mark' parameter but it is blank...
    They appear in the Schedule but have no number...

    If I choose a number well away from the Schedule range and insert it in the 'Mark' column, then the numbers appear in the tagged elevations and plans - which will do for the minute, but I'll have to work out why
    Last edited by ws; 2009-03-02 at 10:15 PM. Reason: Correction

  4. #4
    Certified AUGI Addict patricks's Avatar
    Join Date
    2004-06
    Location
    Memphis TN area
    Posts
    7,047
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    In your window properties, there are instance properties containing a Mark parameter. This is what you use for doors where you give each door a unique number. But with windows, you usually just schedule/show those by type, and the window tag probably references the window Type Mark field. This is located in the window's Type Properties. Just hit Edit/New while viewing instance properties and you should see it.
    Intern Architect, BIM Manager/Coordinator
    AERC, PLLC
    Hernando, Mississippi

    Revit - all up in your voxel space

  5. #5
    AUGI Addict ws's Avatar
    Join Date
    2004-09
    Location
    Ambleside, Lake District, UK
    Posts
    1,222
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    Ah, I see, thanks.

    Yes, I see the Type Mark - it has a different number to the Mark and it is the Mark that shows in the door tags.

    In this particular project all the windows are different which doesn't help.

    I can see that I need to get my 'Mastering Revit Architecture xxxx' books out again

    cheers

  6. #6
    Certifiable AUGI Addict twiceroadsfool's Avatar
    Join Date
    2006-01
    Location
    ---
    Posts
    4,516
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    Yeah, by default i believe Window Tags read the Type Mark (so you can just say window type A, type B... instead of giving it an individual number like we do with doors.

    If you want it to read the Mark value 9so that every window is different), just edit the Window Tag. There is a lable for Type mark, simply switch the parameter to Mark, and it will behave just like your door tags and door numbers...

  7. #7
    AUGI Addict DaveP's Avatar
    Join Date
    2002-12
    Location
    St Paul, MN
    Posts
    1,569
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    You can easily make a Tag for this project that uses the Mark parameter instead of the Type Mark.
    Select one of the Window Tags, then (from the Options Bar), click on Edit Family.
    You should see the Tag graphics with some seemingly random value for the Mark. That value is just a placeholder, It will be replaced in your Project. Click on that text, and then (again on the Options Bar), click on Edit Label.
    You'll probably see "Type Mark" in the right-hand portion on the dialog box. Click on Type Mark, then click the Red arrow the remove Type Mark.
    Select Mark from the list on the left, then the Green Add arrow.

    You'll want to SaveAs now, so this Tag has a different name than the original, and so you can use it again on another project.
    On the Design bar menu, click Load into Project.
    The new Tag will now be available in your project. If you've already placed many of the old ones, never fear, you can just select the (Select All Instances would be handy) and replace them with your new Tag.
    Voila! Now each Window can have it's own unique number.
    Don't forget to change the parameter in your Window Schedule, too!
    Go back to AutoCAD? I'd rather lose my right arm!

  8. #8
    AUGI Addict ws's Avatar
    Join Date
    2004-09
    Location
    Ambleside, Lake District, UK
    Posts
    1,222
    Login to Give a bone
    0

    Default Re: When question marks appear in tags

    thanks guys,

    much appreciated.


Similar Threads

  1. getting rid of ft and inch marks form the tags
    By davel.254027 in forum Revit MEP - General
    Replies: 11
    Last Post: 2010-06-29, 12:51 PM
  2. Help! Problem with tags! (turning into question marks)
    By kappy in forum Revit Architecture - General
    Replies: 6
    Last Post: 2010-05-26, 11:41 PM
  3. ? Question Marks in Tags
    By brenehan in forum Revit Architecture - General
    Replies: 16
    Last Post: 2010-03-01, 08:48 PM
  4. Tag with Question Marks
    By dpollard909366 in forum Revit Architecture - General
    Replies: 13
    Last Post: 2006-06-22, 07:50 PM
  5. Question marks
    By jarkko.rauvanlahti in forum Revit Architecture - Wish List
    Replies: 7
    Last Post: 2005-08-02, 02:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •