Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Debug Build v's Final Build

  1. #1
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Debug Build v's Final Build

    HI.

    I'm in the process of porting my ACA 2009 New Zealand NZS3604 Calculator to Revit. Everything works fine except for the difference between the Debug version and the final build. A little background.

    In VB VS 2008 I have programmed Revit to attach Shared Parameters to certain objects and set default values. This then passes those values as an object to our Referenced in Calculator dll (which is used for ACA as well). This then does calculations etc through interaction with the user using forms with drop down boxes etc. Once the OK button has been pushed it exists and passes back to Revit the revised values and these are then updated on the objects shared parameters.

    This works fantastic when we are using the debugging version as built by VS 2008, as shown in attached file video #1, But unfortunately the final build version doesn't seam to update the shared parameters as shown in Video # 2.

    Does any one have any idea why this would be?

    Thanks in advance

    Phillip Miller
    Attached Files Attached Files

  2. #2
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Here is some of the code where it is getting the values, passing it to our calculator and then setting the values back in Revit.
    Attached Images Attached Images

  3. #3
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    A Followup.

    I have copyed over the final build DLL with the debug version DLL and it now works. The debug ver is slightly larger 33kb compaired with 28kb for the final build. I wonder what the difference between them???

  4. #4
    I could stop if I wanted to Danny Polkinhorn's Avatar
    Join Date
    2003-12
    Location
    San Francisco, CA
    Posts
    448
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Some info here. I haven't noticed a difference in executability (?) of the two builds before. Not sure why you might be having issues.

    -Danny
    Danny Polkinhorn
    Autodesk

  5. #5
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Quote Originally Posted by Danny Polkinhorn View Post
    Some info here. I haven't noticed a difference in executability (?) of the two builds before. Not sure why you might be having issues.

    -Danny
    Hi Danny. Thanks for that. Yes it is very strange. I have never had it happen before either. This is what I found http://haacked.com/archive/2004/02/1...ase-build.aspx Maybe it has something to do with our calculator Dll??

    Nevermind, i'm happy enough using the debug version.

    Cheers

  6. #6
    I could stop if I wanted to Danny Polkinhorn's Avatar
    Join Date
    2003-12
    Location
    San Francisco, CA
    Posts
    448
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    well, you might be unhappy with the debug build if it's slower (and it will be to a certain extent). You should try to determine further why the release build isn't working if it's worth your time.
    Danny Polkinhorn
    Autodesk

  7. #7
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Quote Originally Posted by Danny Polkinhorn View Post
    well, you might be unhappy with the debug build if it's slower (and it will be to a certain extent). You should try to determine further why the release build isn't working if it's worth your time.
    Yes I hear what you are saying but i'm unsure of where to look as I can't debug the problem

  8. #8
    AUGI Addict
    Join Date
    2003-11
    Location
    New Zealand
    Posts
    1,116
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Does it work only in the revit program directory?
    Is the kiwicodes.dll managed or unmanaged code?
    Do you have the source code to the kiwicodes dll?

    Guy

  9. #9
    I could stop if I wanted to
    Join Date
    2007-02
    Location
    Alexandra, New Zealand
    Posts
    237
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    Quote Originally Posted by GuyR View Post
    Does it work only in the revit program directory?
    Is the kiwicodes.dll managed or unmanaged code?
    Do you have the source code to the kiwicodes dll?

    Guy
    Hi Guy. Answers to your questions.
    1. It works in any directory
    2. It will be unmanaged code as it was built before I had visual studio. I think It was written using VB6
    3. I certianally have the source code for KiwCodes.dll

    Not sure if this make any difference.
    Cheers

    Phillip

  10. #10
    AUGI Addict
    Join Date
    2003-11
    Location
    New Zealand
    Posts
    1,116
    Login to Give a bone
    0

    Default Re: Debug Build v's Final Build

    I would say 2 is your problem. Might be time to port it to .NET...

    Guy

Page 1 of 2 12 LastLast

Similar Threads

  1. 2014: Everyone uses the same build
    By MikeJarosz in forum Revit - Worksharing/Worksets/Revit Server
    Replies: 4
    Last Post: 2013-11-14, 09:42 PM
  2. New Build Comments (moved from new build announcement)
    By sfaust in forum Revit Architecture - General
    Replies: 31
    Last Post: 2007-10-15, 08:38 PM
  3. 2008 CD build vs. download build - the same?
    By christo4robin in forum Revit Architecture - General
    Replies: 3
    Last Post: 2007-04-19, 08:51 PM
  4. new build?
    By dsw98 in forum Revit Architecture - General
    Replies: 15
    Last Post: 2006-01-17, 10:34 PM
  5. New Build No.
    By JTF in forum Revit Architecture - General
    Replies: 9
    Last Post: 2003-05-12, 02:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •